Can't see plugin in Eclipse 3.2

1 2 > >> (Page 1 of 2)
  • Hi, is the plugin compatible with Eclipse 3.2 ?
    I am unable to open *.properties files using this plugin.

    • I am surprised it does not, but I never tested it on 3.2.  I will try to do so when I get a chance and get back to you.

      • For both cases following I used the Eclipse 3.2 major realease (i.e. no RC-version, no-overnight-build, no whatever other builds are around).

        I was able to install and use the "Eclipse ResourceBundle Editor" 0.7.5 on Linux at work.

        I was unable to install and use the "Eclipse ResourceBundle Editor" 0.7.5 on my Windows XP machine at home. If try to install it via unzipping, I cannot see anything either: There is neither a properties-panel, nor a possibility to choose the editor via "Open with". 

        Regards, and thanks for your work

        • I managed to fix my problem on my home XP machine. There was a configuration issue of an entirely different plugin, which obviously blocked all new plugins to be registered. I removed this plugin temporarily from the plugin folder.

          Note:  With this "configuration issue" I was unable to install new features via online-update either. That's how I came up with the idea of removing.

    • I just testing in Eclipse 3.2M6 and it worked fine.  It is not the default plugin associated to *.properties files, but it is there and working.  Do you see anything unusual in your logs?

    • I can't seem to be able to run it with 3.2RC1

      • I was able to replicate.  There seem to be references to Eclipse internal classes that no longer exists in 3.2.  I will attempts to provide a fix in the next release.

    • Can you give me a date estimate as it has greatly hampered my productivity at the moment having to go from one machine to another just to insert a couple of keys. Anyhow, I love you plugin!

      • Thanks for the good words!

        I unfortunately cannot give you any accurate estimates (paid jobs go first), but I will attempt to look into providing a fix anytime within a month from now. You can alway submit a patch if you like. ;-)

    • Is this bug related to the issue?
      Would a change in the import to org.eclipse.core.runtime.ListenerList or org.eclipse.equinox.common solve the issue? (sorry I haven't done developed any eclipse plugins yet :( )

      • That might very well be.  I will try to look this up over the week-end if I get a chance.


    • Version 0.7.5 was just released, and contains a fix that makes the plugin works with Eclipse 3.2RC1.  Thanks for reporting and helping with the issue.

    • Thumbs up!

    • I am using the 0.75 and can not see nothing yet

      • Sorry My eclipse is I20060602-1317

        • I just tried version 0.7.5 with Eclipse 3.2RC7 and it worked fine.  Make sure you use a stable release.

    • I am using the 0.75 and eclipse3.2 ,can not see nothing yet

      • Was it installed properly?  Check in "Window/Preference..."  Do you see a "ResourceBundle Editor" entry there?

    • I am now running 3.2 on Win XP and it works fine.  Do you have anything in your eclipse log?  Does the folder shows up in your "plugins" directory?

    • I have problems with your plugin, too. Eclipse doens't detect this plugin.

      Eclipse-version: 3.2 (General Release with MyEclipse 5.0 GA)
      OS: WinXP
      Resourcebundleeditor version: 0.7.5

    • I am unable to associate a view for this plugin, it shows up under window|preferences|ResourceBundle Editor
      However, there is no view for it when I try to open file *.properties

      The version of eclipse that I am using is :
      Eclipse SDK

      Version: 3.2.0
      Build id: M20060628-1325

      on windows XP?

      Could you help?


      Deepali Bhandari (Webmethods)

      • It normally associates itself with the extension, but regardless, you can try this:

        - Go in "Window/Preferences/General/Editors/File Associations".
        - Select (or add if not there) *.properties from the listed file types.
        - If the "Associated editors" list does not contain the ResourceBundle editor, click on the Add button to add it.
        - Optionally, you can then select the ResourceBundle Editor entry and click on the "Default" button.  This will make sure *.properties files are open using the plugin if you have not already specified an association for them.

        Let me know if you are OK after this.

        • after that,it's ok.

    • Gopi

      I am using eclipse 3.2.I added all the plugin files into the plugins folder.I selected *.properties from the listed file type.But it is not displaying "ResourceBunddle editor" in "Associated editor".

    • The plugin does not appear in my window/preferences in eclipse 3.2.2 (fresh downloaded and installed today) either.

1 2 > >> (Page 1 of 2)