Applet alert

  • othiery

    othiery - 2010-01-05

    I've just installed PyUML, which seems to be great, but I can't manage to have it work.

    Every time I trigger the "Create / synchronize UML Model" on a PyDev project (either empty or with pre-existing source code but without any PyUML directory yet) I get an "-Applet alert-" message box stating: "The applet is attempting to access the 'exists'  state attributes of file D:\\path\to\my\project\PyUML\my-project-name.uml".

    I get options for allowing, disallowing or stopping the applet. After allowing I get a second identical message for "PyUMLProfile.uml". The "PyUML" and both files are created but remain empty and no synchronization work.

    Stopping the applet crashes Eclipse if I trigger the same function again.

    I use the following versions:

    - Eclipse Galileo
    -   Eclipse IDE for Java Developers
    -   PyUML Feature 1.2.2
    -   PyDev for Eclipse
    -   UML2 Tools SDK (Incubation) 0.9.0.v200906190654

    Hope this can help,


  • Martin Dittmar

    Martin Dittmar - 2010-01-08

    Hi Olivier,

    thanks for your report!

    Unfortunately, I could not reproduce your problem.
    I tried to download the latest eclipse for Java developers, installed PyDev 1.5.3 and pyuml fron the update site.
    After setting the pyDev interpreter and creating a pydev project, all worked like expected.

    I'm not sure what kind of security function is enabled at your installation… Maybe there is something to disable?

    Sorry I couldn't help you. I will try to reproduce the problem again.

    Anyone has an idea on this? Is this something windows specific?

    Yours, Martin


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks