JavaCC Eclipse Plugin / News: Recent posts

New (Git) repository for the plugin code

The JavaCC Eclipse plugin source configuration management system has moved from CVS to Git, still hosted on SourceForge. See https://sourceforge.net/p/eclipse-javacc/code-git/. Feel free to file a ticket for any question or problem.

Posted by Marc MAZAS 2017-01-17

Version 1.5.33

Version 1.5.33 of the SF JavaCC plugin brings a lot of fixes (color syntaxing, formatting, commenting, call hierarchy view. indentation, completion proposal, hyperlinks, matching character pairs) and adds 2 new functionalities (automatic formating on save option, variables for string substitution).
It embeds JTB 1.4.11.
It is configured to require a JavaSE 1.7+.
See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager or the Eclipse MarketPlace.
It requires Java 1.7+ and Eclipse 3.7+. It has been tested under Eclipse Classic 3.7.2 (Indigo), 4.2.2 (Juno), 4.3.2 (Kepler), 4.4.2 (Luna), 4.5.1 (Mars) on windows x86 / x86_64.

Posted by Marc MAZAS 2016-04-29

Version 1.5.32

Version 1.5.32 of the SF JavaCC plugin brings back the hovers on regular expressions and productions in grammar files as well a minor fixes.
It embeds JTB 1.4.10.
It is configured to require a JavaSE 1.7+.
See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager or the Eclipse MarketPlace.
It requires Java 1.7+ and Eclipse 3.7+. It has been tested under Eclipse Classic 3.7.2 (Indigo), 4.2.2 (Juno), 4.3.2 (Kepler), 4.4.2 (Luna), 4.5.1 (Mars) on windows x86 / x86_64.

Posted by Marc MAZAS 2015-11-13

Version 1.5.30

Version 1.5.30 of the SF JavaCC plugin fixes a clean command problem (regression in version 1.5.29) (see Discussion / Help).
It embeds JTB 1.4.9.
It is configured to require a JavaSE 1.7+ (as 1.6 is obsolete).
See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager or the Eclipse MarketPlace.
It requires Java 1.7+ and Eclipse 3.7+. It has been tested under Eclipse Classic 3.7.2 (Indigo), 4.2.2 (Juno), 4.3.2 (Kepler), 4.4.0 (Luna), on windows x86 / x86_64.

Posted by Marc MAZAS 2015-01-22

Version 1.5.29

Version 1.5.29 of the SF JavaCC plugin fixes a compile command problem found in some environments in version 1.5.28 (see Discussion / Help).
It embeds JTB 1.4.9 which fixes a regression.
It is configured to require a JavaSE 1.7+ (as 1.6 is obsolete).
See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager or the Eclipse MarketPlace.
It requires Java 1.7+ and Eclipse 3.7+. It has been tested under Eclipse Classic 3.7.2 (Indigo), 4.2.2 (Juno), 4.3.2 (Kepler), 4.4.0 (Luna), on windows x86 / x86_64.

Posted by Marc MAZAS 2015-01-18

Version 1.5.28

Version 1.5.28 of the SF JavaCC plugin is shipped now after a long pause !
It brings a lot of fixes and improvements and embeds the new JTB 1.4.8. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.6+ and Eclipse 3.7+. It has been tested under Eclipse Classic 3.7.2 (Indigo), 4.2.2 (Juno), 4.3.2 (Kepler), 4.4.0 (Luna), on windows x86 / x86_64.

Posted by Marc MAZAS 2014-12-30

Version 1.5.27

Version 1.5.27 of the SF JavaCC plugin mainly embeds the new JTB 1.4.7. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.6 and Eclipse 3.6+. It has been tested under Eclipse 3.7 / 3.7.2, x86 / x86_64.

Posted by Marc MAZAS 2012-09-26

Version 1.5.26

Version 1.5.26 of the SF JavaCC plugin gets a fully rewritten and enhanced syntax coloring feature, thanks to Bill F. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.6 and Eclipse 3.6.0+.

Posted by Marc MAZAS 2012-06-29

Version 1.5.25

Version 1.5.25 of the SF JavaCC plugin fixes few bugs and incorporates JTB 1.4.6. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.6 and Eclipse 3.6.0+.

Posted by Marc MAZAS 2012-05-03

Version 1.5.24

Version 1.5.24 of the SF JavaCC plugin fixes few bugs and incorporates JTB 1.4.4. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.6 and Eclipse 3.5.2+.

Posted by Marc MAZAS 2010-12-05

Version 1.5.22

Version 1.5.22 of the SF JavaCC plugin fixes numerous bugs / regressions, and adds some minor enhancements. See the update web site (http://eclipse-javacc.sourceforge.net/).
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.5 or Java 1.6 and Eclipse 3.4 or 3.5.
Next major release is intended to work only with Java 1.5 and Eclipse 3.5

Posted by Marc MAZAS 2010-03-31

Version 1.5.21

Version 1.5.21 of the SF JavaCC plugin fixes a bug in JavaCC wizard.
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.5 or Java 1.6 and Eclipse 3.4 or 3.5.
Next major release is intended to work only with Java 1.5 and Eclipse 3.5

Posted by Marc MAZAS 2010-02-26

Version 1.5.20

Version 1.5.20 of the SF JavaCC plugin fixes different bugs in JavaCC project preferences pages and command line invocation and is shipped with JTB version 1.4.2 which includes different bug fixes.
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.5 or Java 1.6 and Eclipse 3.4 or 3.5.
Next release is intended to work only with Java 1.5 and Eclipse 3.5

Posted by Marc MAZAS 2010-02-25

Version 1.5.19

Version 1.5.19 of the SF JavaCC plugin fixes different bugs in JavaCC project preferences pages and includes JTB version 1.4.1 which includes different bug fixes.
It can be downloaded or installed through the Eclipse Update Manager.
It requires Java 1.5 or Java 1.6 and Eclipse 3.4 or 3.5.
Next release is intended to work only with Java 1.5 and Eclipse 3.5.

Posted by Marc MAZAS 2010-02-20

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks