Maven plugin does not pull in dependencies?

  • Anonymous - 2012-08-20

    I tried to add the Maven plugin as per the instructions in the build/plugins sections


    When I try to run it against an existing jacoco.exec file from commandline it complains about missing libraries…shouldn't those be pulled in automatically?

    mvn jacoco:report -DdataFile=target/jacoco.exec

    then I get

    [INFO] ------------------------------------------------------------------------
    [INFO] ------------------------------------------------------------------------
    [INFO] Internal error in the plugin manager executing goal 'org.jacoco:jacoco-maven-plugin:': Unable to load the mojo 'org.jacoco:jacoco-maven-plugin:' in the plugin 'org.jacoco:jacoco-maven-plugin'. A required class is missing: org/apache/maven/doxia/siterenderer/RendererException

    I am on Maven 2.2.1 (manual install) on Fedora 17, 64 bit, JDK7.

  • Marc R. Hoffmann

    Looks like some API or dependency problem. Actually we test JaCoCo plugin against Maven 3.x only.

  • Marc R. Hoffmann

    You might try clearing your local maven repo, this might also be the cause.

  • Anonymous - 2012-08-20

    Yes, the Maven repo was corrupt. Caused by Fedora originally installing Maven 3 even if you specify the "maven2" package. After I cleaned it out report plugin worked as expected.

    thanks for the suggestion!


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks