Keyboard shortcuts

Help
David
2011-11-06
2013-04-16
  • David

    David - 2011-11-06

    I love Eaglemode! Thank you for this magnificent and exciting work!

    I did have a question. I am using version 0.82.0 compile from sourcecode on an openSUSE 11.3 GNU/Linux machine.

    I used to have older versions installed and the keyboard shortcuts worked, but for some reason, I am unable to get the keyboard shortcuts to work. I seem to recall that they did work at one time, but I just tried rolling back as far as 0.78.0 (also trying 0.80.0, and 0.79.0) and they still don't seem to work in those versions either. I am almost certain that at one time, these keyboard shortcuts worked before, but they do nothing now. For example, pressing page-up or page-down does absolutely nothing.
    No debugging messages appear in the terminal when I turn on debugging and attempt to use the keyboard shortcut keys.
    Interestingly enough, the shift key works when mouse-zooming (it is supposed to slow zooming down and movement).
    But that seems to be the limit as far as the keyboard goes. For example,
    Does anyone perhaps know what I should be looking at in order to troubleshoot the problem?
    Thank you in advance for your thoughts on this and again, many thanks for this wonderful program!

     
  • Oliver Hamann

    Oliver Hamann - 2011-11-07

    That is a very strange bug. I tried to reproduce it with 0.82.0 on openSUSE 11.3, but all keys are working.

    How is it with keyboard input in edit fields? For example, can you rename a file?

     
  • David

    David - 2011-12-11

    Sorry for the delay in my reply. I am going to change my monitoring preferences so I reply quicker next time. Thank you for trying to replicate.
    Yes, I agree that this is most strange, and I have never seen this problem before. I did go ahead and download v0.83 today (thank you for the continued development - I love this program and I am excited to see the development continue). I still am experiencing the problem.
    You right - the input and edit fields are not working either. For example, I cannot rename a file. Most unusual. Now, when I select a file, and click "rename" above, the rename dialog comes up, but no keystrokes are seen. If I click in this dialog, a flashing cursor is there, but it will not echo keystrokes into that area, and it's impossible to move that cursor using the arrow keys.
    I wish I knew what it was; it seems like something maybe isolated to this  install.
    Thank you again for thinking about it and looking into it.

     
  • Oliver Hamann

    Oliver Hamann - 2011-12-13

    I would like to try again reproducing the bug on my virtualized openSUSE system. Therefore I have some more questions: Which window manager / desktop environment (KDE, Gnome, …) are you using? And which locale? And which X server? Is there any extraordinary thing with your OS installation?

     
  • David

    David - 2011-12-14

    Thanks for having a second look at it.
    Perhaps you might not put too much time and effort into it because it could very well be something isolated to my system. Like you, I was beginning to wonder about it the past few days, and also trying to ponder what it is about this that's extra-ordinary, but I cannot think of anything. Most everything is installed from packages; there might be some programs that were compiled from source code, but none affecting the window manager or the input devices or input drivers that I can think of.
    I am using KDE4 for a window manager; this installed from the openSUSE 11.3 packages, and the version output is 'Platform Version 4.4.4 (KDE 4.4.4) "release 3"'. The locale is "Not set (Generic English". Also, the keyboard layout is set to "disabled" in the keyboard layout section (this is under systemsettings -> Regional and Languages -> Keyboard layout). However, when I the radio button to "enable keyboard layouts" then it defaults to "USA" and uses the "US" keyboard map, but this still has no effect on Eaglemode. I didn't try setting this and restarting KDE though. I might try that.
    For the Xorg server, the version output is:

    X.Org X Server 1.8.0
    Release Date: 2010-04-02
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX

    So then I was thinking about trying Gnome, because I haven't thought of that - this is a great idea! So before that, I figured "why not try it without KDE?" So I just forked another Xorg instance (like using xinit - :1 for example) and without launching any window manager/desktop environment, and just leaving the standard xterm "xinit" window, and then typing eaglemode into there, and the keyboard works!!! I was so pleased!
    I will try gnome later, but I am starting to believe that this is definitely a KDE problem.
    Many kind thanks again for checking into it but don't make it a super priority and don't lose any sleep over it. If you do get some spare time and you are able to find anything though, then please let me know as I love this program so much.
    Kind Regards and thank you again!

     
  • Oliver Hamann

    Oliver Hamann - 2011-12-14

    Currently I can spare some time and really would like to fix the bug if possible. If it happens to you, it could also happen to others. I have the same KDE and X server version, but the keys are working here. So it seems I am unable to reproduce the effect on my system. I think there is no need to try out Gnome. The next step could be that I send you an Eagle Mode version which produces much log information about the keyboard events and how they are handled, in the hope that this helps me to fix the problem, at least after some cycles of adaptations. If you agree and have fun and a little time for that, we could continue the communication via email. Mine is: olha@users.sourceforge.net

     
  • Oliver Hamann

    Oliver Hamann - 2011-12-21

    @all: Thanks to the great help of youknowwho72 it is now clear that keyboard input may not work in Eagle Mode when using the X input method "ibus" or "SCIM", because the XFilterEvent function eats all keys then. The bug looks similar to:
    http://bugs.sun.com/view_bug.do?bug_id=6506617
    https://bugs.freedesktop.org/show_bug.cgi?id=7869

    The only workaround we know for now is to set XMODIFIERS to some other input method. So, in a shell please type:

      export XMODIFIERS=@im=local

    or:

      export XMODIFIERS=

    And then start Eagle Mode from that shell.

    You could also set XMODIFIERS in the profile or bashrc. But than it affects all X programs.

    This is not really a satisfying fix. Does anybody know a programmatically solution which does not disable the input method?

     

Log in to post a comment.