mkfs.ext3 issues

Help
sriram
2009-02-10
2012-11-28
  • sriram

    sriram - 2009-02-10

    Hi,
      I am trying to format a 8GB SDcard.

      I have created a 2GB partition using fdisk.

      When i try to do a mkfs.ext on it i get the following messages:

      What could be wrong?

      I have tried with quite a few versions of mkfs.ext3, but without any success.

      I have also tried with different partition sizes without success.

      What is the highest partition size mkfs.ext3 supports?

    Regards,
    sriram

    # mkfs.ext3 /dev/mmcblk1p2
    mke2fs 1.41.4 (27-Jan-2009)
    ext2fs_check_if_mount: No such file or directory while determining whether /dev/mmcblk1p2 is mounted.
    Filesystem label=
    OS type: Linux
    Block size=4096 (log=2)
    Fragment size=4096 (log=2)
    497760 inodes, 1990912 blocks
    99545 blocks (5.00%) reserved for the super user
    First data block=0
    Maximum filesystem blocks=2042626048
    61 block groups
    32768 blocks per group, 32768 fragments per group
    8160 inodes per group
    Superblock backups stored on blocks:
            32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

    Writing inode tables: done                           
    Creating journal (32768 blocks): mkfs.ext3: No such file or directory
            while trying to create journal
    #

     

     
    • Jonathan Liversidge

      What does...

      # df -h

      ...return?  Is the device already mounted?

      If so, you will need to unmount before running mkfs...

      # umount /MOUNT/POINT

      Also, you'll need to check the disk for an existing partition table. Run...

      # fdisk -l

      ...to see what's on the device (assuming of course that the OS has detected the device in the first place).

      Re Max Partition Size
      This depends upon the block size specified.

      See...

      http://en.wikipedia.org/wiki/Ext3#Size_limits

      Hope this helps.

      jl

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks