superblock write time is in the future

Help
2005-12-16
2012-11-28
  • Andrew Sackville-West

    using e2fsprogs 1.39 on debian unstable with 2.6.14 kernel. recently upgraded to this and its a recent package (Dec 10, 2005 build) and now I get what I assume are fsck errors on every(!) partition on every(!) boot. Even after bringing the whole system down to init 1, umount'ing all fs and fsck'ing, til they show "clean" I still get the same error after reboot.

    looks like this

    UNEXPECTED INCONSISTENCY: SuperBlock last write time is in the future.

    which halts my boot and dumps me to a shell.

    any help is appreciated.

     
    • Andrew Sackville-West

      Revised output:

      I can't seem to get this output from my logs, so I rebooted to get it exactly right. Here is the error I'm getting:

      /dev/hda3: Superblock last mount time is in the future

      /dev/hda3: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY

      and it repeats this for every partition on every disk (2 disks here). this halts my boot and drops to a shell. do fsck on every partition and then reboot. same error. something is happening each time I reboot.

      version is (per -v output): 1.39-WIP (12-10-2005)
      though apt-cache show e2fsprogs  says version 1.38 in one location and 1.38-1.39 WIP in another.

      I will try to downgrade to an older version if I can and report back.

       
    • Andrew Sackville-West

      Further information.

      1) downgrading e2fsprogs in debian is practically impossible due to dependencies but...

      2) ran knoppix 4.0 and used it to fsck all my partitions (it uses e2fsprogs 1.38 (30-Jun-2005)

      3) rebooted into back into knoppix and checked partitions with fsck, all clean so, mounted a couple of them,

      4) rebooted back into debian: bang same error on all partions whether previously mounted in knoppix or not.

      is there a problem in 1.39?

      A

       
    • Andrew Sackville-West

      completed downgrade to debian package 1.38-2 (testing) and the problem is resolved. bug report filed with debian.

       

Log in to post a comment.