#414 please enable wake on lan (WOL) without shutdown/reboot

open
None
in-kernel_driver
1
2015-08-20
2014-05-22
Lukas Pirl
No

As the driver's documentation (Section "Enabling Wake on LAN* (WoL)") describes, wake on LAN settings are only applied upon reboot or shutdown.
This is prevents the obvious use case to WOL a machine from suspend (S1-S4) but not from power-off (S5).

Detailed use case:

  1. WOL disabled
  2. manual system power on
  3. set WOL upon unicast
  4. suspend system when idle
  5. wake system by unicast
  6. [eventually back to step 4]
  7. disable WOL
  8. shutdown

Discussion

  • Lukas Pirl

    Lukas Pirl - 2014-05-22
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,6 +1,7 @@
     As the driver's [documentation](http://www.cyberciti.biz/files/linux-kernel/Documentation/networking/e1000e.txt) (Section "Enabling Wake on LAN* (WoL)") describes, wake on LAN settings are only applied upon reboot or shutdown.
     This is prevents the obvious use case to WOL a machine from suspend (S1-S4) but not from power-off (S5).
    -Desired usage:
    +
    +Detailed use case:
    
     1. WOL disabled
     2. manual system power on
    
     
  • Todd Fujinaka

    Todd Fujinaka - 2014-06-20
    • assigned_to: dertman
     
  • dertman

    dertman - 2014-06-20

    The use case you describe is already supported with the current driver. You are misinterpreting the documentation. Here is the section you are referring to:

    Enabling Wake on LAN* (WoL)


    WoL is configured through the Ethtool* utility. For instructions on
    enabling WoL with Ethtool, refer to the Ethtool man page.

    WoL will be enabled on the system during the next shut down or reboot.

    When the system is up and running in S0, WoL is not configured in the adapter. It is not until the system is transitioning into a deeper Sx state (S3, S4, S5) that WoL is configured.

    The documentation is stating that once you use ethtool to set what modes of WoL are active (some mix of p, u, m, b, g or none), then the next time you transition into a deeper Sx state, that is what will be configured in the adapter, and the system will wake on the defined event(s).

    I hope this clears up any confusion.

     
  • dertman

    dertman - 2014-06-20
    • status: open --> closed
     
  • Lukas Pirl

    Lukas Pirl - 2014-06-22

    Thanks for your reply!
    Hm, I somehow had the feeling that I could reproduce the misinterpreted behavior. :) Anyways, since I have no access to the "affected" system anymore, I have to believe you I think.

    I vote for changing the documentation since it is prone for misinterpretation, for example by changing

    WoL will be enabled on the system during the next shut down or reboot.

    to

    WoL will be enabled when the system is transitioning into a deeper Sx state (S1-S5).

     
  • Lukas Pirl

    Lukas Pirl - 2014-06-27

    Okay I tested it again: Do you have an explanation why

    ethtool -s eth0 wol u && poweroff
    

    works as expected (wake on unicast), whereas

    ethtool -s eth0 wol u && pm-suspend
    

    does not?

     
  • Lukas Pirl

    Lukas Pirl - 2014-07-06
    • status: closed --> open
     
  • Lukas Pirl

    Lukas Pirl - 2014-07-06

    After further investigations, it seems that the adapter gets reseted between

    ethtool -s eth0 wol u && pm-suspend
    

    and the actual suspend by the kernel.

    After

    ethtool -s eth0 wol u
    

    ethtool eth0 shows the settings as expected by .

    I checked the debug output from pm-suspend and it does not seem to manipulate the device settings.

    To verify the WoL settings directly prior the suspend, I put a script in /etc/pm/sleep.d that prints ethtool eth0.
    It turned out that the settings do not match the ones that were set and checked in beforehand. They are set to the default "wake on Magic Paket" again.

    If I put a script in /etc/pm/sleep.d that sets the WoL settings, everything works as expected (great!).

    Although this might not be related to e1000e, it would be great if you have some pointers why this might happen or who to contact so that this confusing behavior can be eliminated.

     
  • Todd Fujinaka

    Todd Fujinaka - 2015-05-12
    • assigned_to: dertman --> Yanir Lubetkin
     
  • Todd Fujinaka

    Todd Fujinaka - 2015-08-20
    • assigned_to: Yanir Lubetkin --> Raanan Avargil
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks