#358 Intel 82571EB - eth1 transmit queue 0 timed out

closed
nobody
e1000e (109)
in-kernel_driver
1
2014-08-21
2012-09-18
Oliver
No

Under 3.4 (e1000e 1.9.5-k) I am finding that during times of load, eth1 of a 2-port 82571EB is timing out and being reset.

Possibly of note is that eth1 is on a trunked VLAN port and services ~20 VLANs.

I note others have had issues related to BQL, is there any mileage in disabling BQL or is there an upstream patch to address this issue?

[228502.692716] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x250/0x260()
[228502.692720] Hardware name: PowerEdge R310
[228502.692723] NETDEV WATCHDOG: eth1 (e1000e): transmit queue 0 timed out
[228502.692726] Modules linked in: ip_vs libcrc32c sch_htb xt_addrtype xt_set ip_set_hash_ip ip_set_hash_netport ip_set_bitmap_ip ip_set_hash_ipportnet ip_set_hash_ipport ip_set_hash_net ip_set bnx2 e1000e iTCO_wdt i7core_edac
[228502.692748] Pid: 0, comm: swapper/0 Not tainted 3.4.10-3-zl #3
[228502.692751] Call Trace:
[228502.692754] <IRQ> [<ffffffff810492db>] ? warn_slowpath_common+0x7b/0xc0
[228502.692770] [<ffffffff810493d5>] ? warn_slowpath_fmt+0x45/0x50
[228502.692776] [<ffffffff8151ee10>] ? dev_watchdog+0x250/0x260
[228502.692782] [<ffffffff8105406f>] ? run_timer_softirq+0x11f/0x240
[228502.692787] [<ffffffff8151ebc0>] ? qdisc_reset+0x40/0x40
[228502.692793] [<ffffffff8104eed8>] ? __do_softirq+0x98/0x120
[228502.692800] [<ffffffff810a857e>] ? handle_irq_event_percpu+0x7e/0x140
[228502.692807] [<ffffffff81696a0c>] ? call_softirq+0x1c/0x30
[228502.692812] [<ffffffff8100460d>] ? do_softirq+0x4d/0x80
[228502.692817] [<ffffffff8104f1ce>] ? irq_exit+0x8e/0xb0
[228502.692821] [<ffffffff810044cc>] ? do_IRQ+0x5c/0xd0
[228502.692829] [<ffffffff81694f67>] ? common_interrupt+0x67/0x67
[228502.692830] <EOI> [<ffffffff812c15d3>] ? intel_idle+0xe3/0x150
[228502.692835] [<ffffffff812c15af>] ? intel_idle+0xbf/0x150
[228502.692839] [<ffffffff814c5c5c>] ? cpuidle_idle_call+0x8c/0xf0
[228502.692843] [<ffffffff8100b38a>] ? cpu_idle+0x7a/0xb0
[228502.692847] [<ffffffff81939b25>] ? start_kernel+0x32d/0x338
[228502.692849] [<ffffffff8193957f>] ? repair_env_string+0x5c/0x5c
[228502.692851] ---[ end trace 4737d380d1f72bd3 ]---
[228502.692868] e1000e 0000:05:00.1: eth1: Reset adapter

Kind Regards,
Oliver

Discussion

  • Oliver

    Oliver - 2012-09-18
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -2,7 +2,7 @@
    
     Possibly of note is that eth1 is on a trunked VLAN port and services ~20 VLANs.
    
    -I note others have had issues related to BQL, is there any mileage in disabling BQL or is there an upstream path to address this issue?
    +I note others have had issues related to BQL, is there any mileage in disabling BQL or is there an upstream patch to address this issue?
    
     [228502.692716] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x250/0x260()
     [228502.692720] Hardware name: PowerEdge R310
    
     
  • Oliver

    Oliver - 2012-09-18
    • labels: --> e1000e
     
  • Oliver

    Oliver - 2012-09-18
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,4 +1,4 @@
    -Under 3.4 I am finding that during times of load, eth1 of a 2-port 82571EB is timing out and being reset.
    +Under 3.4 (e1000e 1.9.5-k) I am finding that during times of load, eth1 of a 2-port 82571EB is timing out and being reset.
    
     Possibly of note is that eth1 is on a trunked VLAN port and services ~20 VLANs.
    
     
  • Tushar Dave

    Tushar Dave - 2012-09-27

    Have you tried latest e1000e from sourceforge?

     
  • Oliver

    Oliver - 2012-10-08

    I have not, although I can now say that the problem appears to be related to the use of the HTB classful qdisc (RED and pfifo as children)

    after reverting back to pfifo_fast as the root qdisc, the problem has ceased.

     
  • Todd Fujinaka

    Todd Fujinaka - 2013-07-09

    Closing.

     
  • Todd Fujinaka

    Todd Fujinaka - 2013-07-09
    • status: open --> closed
     

Log in to post a comment.