#138 Support for E4

closed
nobody
None
5
2011-04-22
2011-04-22
Anonymous
No

This is just a friendly, advanced, reminder to add support for E4. I was testing out Eclipse SDK 4.1 (Eclipse SDK Version: 4.1.0 Build id: I20110421-0500) today and wanted to see if EPIC would install / work.

I tried installing via http://e-p-i-c.sf.net/updates/testing/, EPIC v0.6.39, and got this message:

Cannot complete the install because of a conflicting dependency.
Software being installed: EPIC 0.6.39 (org.epic.feature.main.feature.group 0.6.39)
Software currently installed: Eclipse SDK 4.1.0.I20110421-0500 (org.eclipse.sdk.ide 4.1.0.I20110421-0500)
Only one of the following can be installed at once:
Eclipse Platform 3.7.0.v201104061223 (org.eclipse.platform 3.7.0.v201104061223)
Eclipse Platform 4.1.0.v20110407-2200 (org.eclipse.platform 4.1.0.v20110407-2200)
Eclipse Platform 4.1.0.v20110420-1420 (org.eclipse.platform 4.1.0.v20110420-1420)
Eclipse Platform 4.1.0.v20110412-2200 (org.eclipse.platform 4.1.0.v20110412-2200)
Eclipse Platform 4.1.0.v20110421-0500 (org.eclipse.platform 4.1.0.v20110421-0500)
Eclipse Platform 3.7.0.v201104210100 (org.eclipse.platform 3.7.0.v201104210100)
Eclipse Platform 3.7.0.v201012081300 (org.eclipse.platform 3.7.0.v201012081300)
Eclipse Platform 4.1.0.v20110419-2200 (org.eclipse.platform 4.1.0.v20110419-2200)
Eclipse Platform 4.1.0.v20110414-2200 (org.eclipse.platform 4.1.0.v20110414-2200)
Eclipse Platform 4.1.0.v20110415-1030 (org.eclipse.platform 4.1.0.v20110415-1030)
Eclipse Platform 4.1.0.v20110127-2200 (org.eclipse.platform 4.1.0.v20110127-2200)
Eclipse Platform 4.1.0.v20110415-1401 (org.eclipse.platform 4.1.0.v20110415-1401)
Eclipse Platform 3.7.0.v201103101119 (org.eclipse.platform 3.7.0.v201103101119)
Eclipse Platform 3.7.0.v201103220800 (org.eclipse.platform 3.7.0.v201103220800)
Eclipse Platform 4.1.0.v20101202-1530 (org.eclipse.platform 4.1.0.v20101202-1530)
Eclipse Platform 3.7.0.v201104121532 (org.eclipse.platform 3.7.0.v201104121532)
Eclipse Platform 4.1.0.v20110325-1411 (org.eclipse.platform 4.1.0.v20110325-1411)
Eclipse Platform 3.7.0.v201102150800 (org.eclipse.platform 3.7.0.v201102150800)
Eclipse Platform 3.7.0.v201104191004 (org.eclipse.platform 3.7.0.v201104191004)
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.r20110302-9gF7SHCIFt6ms-lIjrC6vK_XO-IabJMKu (org.eclipse.platform.feature.group 3.7.0.r20110302-9gF7SHCIFt6ms-lIjrC6vK_XO-IabJMKu)
To: org.eclipse.platform [3.7.0.v201103101119]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20100923-9fF7MHDqFsAkplGz0n61z-yU57WHoz0JdMfaI (org.eclipse.platform.feature.group 3.7.0.v20100923-9fF7MHDqFsAkplGz0n61z-yU57WHoz0JdMfaI)
To: org.eclipse.platform [3.7.0.v201012081300]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110209-9fF7QHFQFsAlpyfO4rKw4lNW200gZcvGr (org.eclipse.platform.feature.group 3.7.0.v20110209-9fF7QHFQFsAlpyfO4rKw4lNW200gZcvGr)
To: org.eclipse.platform [3.7.0.v201102150800]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110315-9gF7SHCJFt3cwDesZ5LrhrcdfooveV1uWqcqPF (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHCJFt3cwDesZ5LrhrcdfooveV1uWqcqPF)
To: org.eclipse.platform [3.7.0.v201103220800]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110315-9gF7SHIZFt3cwDktE9WrW9XEj1iOiW9fgbhxME (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHIZFt3cwDktE9WrW9XEj1iOiW9fgbhxME)
To: org.eclipse.platform [3.7.0.v201104061223]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110315-9gF7SHLgFt4cwDmoWF-DvhVMEUrQfXBVSritR5 (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHLgFt4cwDmoWF-DvhVMEUrQfXBVSritR5)
To: org.eclipse.platform [3.7.0.v201104121532]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110315-9gF7SHNFFt4cwDooaDrDsaVdEWi0oMLWlh6mbT (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHNFFt4cwDooaDrDsaVdEWi0oMLWlh6mbT)
To: org.eclipse.platform [3.7.0.v201104191004]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110315-9gF7SHNFFt4cwDqmhLPCtURdWWmWmO0Plh6mbT (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHNFFt4cwDqmhLPCtURdWWmWmO0Plh6mbT)
To: org.eclipse.platform [3.7.0.v201104210100]
Cannot satisfy dependency:
From: Eclipse Platform 4.1.0.v20110418-9IF70GmkFnUTMdAxlLeyIIOTFUhlSeaStOas1r2L1InnZ (org.eclipse.platform.feature.group 4.1.0.v20110418-9IF70GmkFnUTMdAxlLeyIIOTFUhlSeaStOas1r2L1InnZ)
To: org.eclipse.platform [4.1.0.v20110421-0500]
Cannot satisfy dependency:
From: Eclipse Project SDK 4.1.0.v20110418-7T7fA7F8Yw_bVbWLCz-tyu2NgX2Xz-rz-X_OJMgM7iT_E (org.eclipse.sdk.feature.group 4.1.0.v20110418-7T7fA7F8Yw_bVbWLCz-tyu2NgX2Xz-rz-X_OJMgM7iT_E)
To: org.eclipse.platform.feature.group [4.1.0.v20110418-9IF70GmkFnUTMdAxlLeyIIOTFUhlSeaStOas1r2L1InnZ]
Cannot satisfy dependency:
From: Eclipse SDK 4.1.0.I20110421-0500 (org.eclipse.sdk.ide 4.1.0.I20110421-0500)
To: org.eclipse.sdk.feature.group [4.1.0.v20110418-7T7fA7F8Yw_bVbWLCz-tyu2NgX2Xz-rz-X_OJMgM7iT_E]
Cannot satisfy dependency:
From: EPIC 0.6.39 (org.epic.feature.main.feature.group 0.6.39)
To: org.eclipse.platform.feature.group [3.2.0,4.0.0)

Discussion

  • Jan Ploski

    Jan Ploski - 2011-04-22

    The reported dependency problem is fixed in 0.6.40.

    You'll have to find out yourself whether or not everything works as expected in 4.1. (I gave it a quick try and observed no immediate problems.)

     
  • Jan Ploski

    Jan Ploski - 2011-04-22
    • status: open --> closed
     

Log in to post a comment.