STDOUT not sent to eclipse console

Help
2012-05-22
2013-05-20
  • Troy Hughes

    Troy Hughes - 2012-05-22

    Hi, there.  I am trying to debug my script in Eclipse and I do not see the output from print statements in the console.  However, If I make a short hello world script I do see the output in my console. I can't image that it is a script problem because I can run my script from the command line without issue.  I do have some org.epic.debug errors in the error log but I am unable to tell if they are related.  I have included the error log below.

    !ENTRY org.epic.debug 1 0 2012-05-22 12:11:34.480
    !MESSAGE Starting Perl debugger:
    Command line:
    perl
    -IC:/Users/th477f/Documents/workspace/.metadata/.plugins/org.epic.debug
    -IC:/depots/PERF/PERF-DEPOT/Grinder-Infrastructure/scripts/test_provisioning
    -d
    -Mautoflush_epic
    C:/depots/PERF/PERF-DEPOT/Grinder-Infrastructure/scripts/test_provisioning/grinderTestDistribution.pl
    -te
    Lynnwood Grinder LoadGen Farm
    -sr
    C:\depots\PERF\PERF-DEPOT\Grinder-Infrastructure\scripts\test_provisioning
    -ef
    grinder.environments.xml
    -sf
    grinder.scenarios.xml
    -ts
    HR Prod - 2500 Users
    -od
    output
    Working directory: C:\depots\PERF\PERF-DEPOT\Grinder-Infrastructure\scripts\test_provisioning
    Environment:
    USERPROFILE=C:\Users\th477f
    USERDNSDOMAIN=ITSERVICES.SBC.COM
    HOMEDRIVE=H:
    DRU_BIN_DIR=C:\Program Files\DRU\BIN
    COMMONPROGRAMFILES=C:\Program Files\Common Files
    APPDATA=C:\Users\th477f\AppData\Roaming
    PROGRAMFILES=C:\Program Files
    OS=Windows_NT
    LOCALAPPDATA=C:\Users\th477f\AppData\Local
    DEFLOGDIR=C:\ProgramData\McAfee\DesktopProtection
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
    VS100COMNTOOLS=c:\Program Files\Microsoft Visual Studio 10.0\Common7\Tools\
    NUMBER_OF_PROCESSORS=4
    VSEDEFLOGDIR=C:\ProgramData\McAfee\DesktopProtection
    FP_NO_HOST_CHECK=NO
    HOMEPATH=\
    PATH=C:/Program Files/Java/jre6/bin/client;C:/Program Files/Java/jre6/bin;C:/Program Files/Java/jre6/lib/i386;C:\Program Files\RSA SecurID Token Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Enterprise Vault\EVClient\;c:\tools;C:\Program Files\Notepad++;C:\Program Files\Microsoft Network Monitor 3\;C:\Program Files\SlikSvn\bin;c:\tools;C:\Program Files\Java\jre6\bin;C:\strawberry\c\bin;C:\strawberry\perl\site\bin;C:\strawberry\perl\bin;C:\Program Files\eclipse;
    PERL_YAML_BACKEND=YAML
    USERDOMAIN=ITSERVICES
    PROGRAMDATA=C:\ProgramData
    TERM=dumb
    PROCESSOR_ARCHITECTURE=x86
    JAVA_APP_ROOT=C:\JavaApps
    PSMODULEPATH=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
    TEMP=C:\Users\th477f\AppData\Local\Temp
    %FAVORITESDIR%=C:\Users\th477f\Favorites
    PERL_JSON_BACKEND=JSON::XS
    SYSTEMDRIVE=C:
    PROCESSOR_REVISION=2505
    SYSTEMROOT=C:\Windows
    COMSPEC=C:\Windows\system32\cmd.exe
    HOMESHARE=\\CAFRFD1CDFILE04.itservices.sbc.com\th477f$
    LOGONSERVER=\\CAFRFD1ADSSRV92
    SESSIONNAME=Console
    WINDIR=C:\Windows
    PROCESSOR_LEVEL=6
    PUBLIC=C:\Users\Public
    JYTHON_DIR=c:\JavaApps\jython2.5.2
    USERNAME=th477f
    DRU_APP_DIR=C:\Program Files\DRU
    PROCESSOR_IDENTIFIER=x86 Family 6 Model 37 Stepping 5, GenuineIntel
    UATDATA=C:\Windows\system32\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
    JT=C:\Program Files\Java\jdk1.6.0_31\bin
    ALLUSERSPROFILE=C:\ProgramData
    COMPUTERNAME=WACDTL03JG8540
    TMP=C:\Users\th477f\AppData\Local\Temp
    PERLDB_OPTS=RemotePort=141.204.54.55:5000 DumpReused ReadLine=0
    !ENTRY org.tigris.subversion.subclipse.core 4 -6 2012-05-22 12:11:35.678
    !MESSAGE org.tigris.subversion.javahl.ClientException: Unsupported working copy format
    svn: This client is too old to work with working copy 'C:\depots\PERF\PERF-DEPOT\Grinder-Infrastructure\scripts\test_provisioning'.  You need
    to get a newer Subversion client, or to downgrade this working copy.
    See http://subversion.tigris.org/faq.html#working-copy-format-change
    for details.
    !STACK 0
    org.tigris.subversion.svnclientadapter.SVNClientException: org.tigris.subversion.javahl.ClientException: Unsupported working copy format
    svn: This client is too old to work with working copy 'C:\depots\PERF\PERF-DEPOT\Grinder-Infrastructure\scripts\test_provisioning'.  You need
    to get a newer Subversion client, or to downgrade this working copy.
    See http://subversion.tigris.org/faq.html#working-copy-format-change
    for details.
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:495)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:467)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:460)
        at org.tigris.subversion.subclipse.core.status.RecursiveStatusUpdateStrategy.statusesToUpdate(RecursiveStatusUpdateStrategy.java:62)
        at org.tigris.subversion.subclipse.core.status.StatusCacheManager.basicGetStatus(StatusCacheManager.java:217)
        at org.tigris.subversion.subclipse.core.status.StatusCacheManager.getStatus(StatusCacheManager.java:188)
        at org.tigris.subversion.subclipse.core.status.StatusCacheManager.getStatus(StatusCacheManager.java:136)
        at org.tigris.subversion.subclipse.core.resources.LocalResource.getStatus(LocalResource.java:208)
        at org.tigris.subversion.subclipse.core.resources.LocalFolder.getStatus(LocalFolder.java:288)
        at org.tigris.subversion.subclipse.core.resourcesListeners.RevertResourceManager.processResources(RevertResourceManager.java:151)
        at org.tigris.subversion.subclipse.core.resourcesListeners.RevertResourceManager.resourceChanged(RevertResourceManager.java:112)
        at org.eclipse.core.internal.events.NotificationManager$1.run(NotificationManager.java:291)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285)
        at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149)
        at org.eclipse.core.internal.resources.Workspace.broadcastBuildEvent(Workspace.java:381)
        at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:139)
        at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    Caused by: org.tigris.subversion.javahl.ClientException: Unsupported working copy format
    svn: This client is too old to work with working copy 'C:\depots\PERF\PERF-DEPOT\Grinder-Infrastructure\scripts\test_provisioning'.  You need
    to get a newer Subversion client, or to downgrade this working copy.
    See http://subversion.tigris.org/faq.html#working-copy-format-change
    for details.
        at org.tigris.subversion.javahl.SVNClient.status(Native Method)
        at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(AbstractJhlClientAdapter.java:481)
        ... 18 more
    !ENTRY org.epic.debug 4 0 2012-05-22 12:11:36.002
    !MESSAGE An error occurred while parsing debugger variables; contents of the Variables view may be inaccurate. Failure caused by string: {NS00000003$^AS00000002''NS00000003$^DS000000010NS00000003$^ES0000003e'An operation was attempted on something that is not a socket'NS00000003$^FS000000012NS00000003$^HS00000003256NS00000003$^LS00000003''NS00000003$^OS00000009'MSWin32'NS00000003$^PS000000041855NS00000010$^RE_TRIE_MAXBUFS0000000565536NS00000003$^SS000000011NS00000007$^TAINTS000000010NS00000009$^UNICODES000000010NS00000003$^VS00000017version=HASH(0x18f1994)S00000003...INS0000000a'original'S00000009'v5.14.2'NS00000004'qv'S000000011NS00000009'version'S00000010ARRAY(0x18f1984)S00000003...INS00000003[0]S000000015NS00000003[1]S0000000214NS00000003[2]S000000012OONS00000003$^WS000000010NS0000000e$^WARNING_BITSS0000000f'
    
     
  • Jan Ploski

    Jan Ploski - 2012-05-22

    This may be because of STDOUT buffering. Try setting $| = 1.

    Generally, it is recommended to upgrade to EPIC 'testing' for better debugging support.

     
  • Troy Hughes

    Troy Hughes - 2012-05-22

    $| = 1 did not work. 

    How does one go about upgrading to EPIC 'testing'? I don't see any reference to this online.

     
  • Jan Ploski

    Jan Ploski - 2012-05-22

    Help > Install New Software…
    Add update site "http://e-p-i-c.sf.net/updates/testing
    Install EPIC from the new update site - it should replace the previously installed "stable" version.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks