PadWalker module whereabouts

  • liesel.mueller

    liesel.mueller - 2007-01-18

    Dear community

    I have downloaded the EPIC-plug-in for Eclipse and installed. I am running this on a Windows machine, with ActiveState Perl installed on it. As I have the wrong PadWalker package installed, I would like to install the PadWalker module from the EPIC homepage as described in the user's guide. Unfortunately, I cannot find this module anywhere on Could you provide me with a more precise link to the module?

    Thanks a lot for your help and I am really enjoying the EPIC plug-in!

    • Jan Ploski

      Jan Ploski - 2007-01-18

      If you have the current version of Perl from ActiveState, then you can install the PadWalker module using ppm from their repository. There is no longer a need to download it from EPIC web site. The user guide is outdated in this respect.

    • Mike Whittaker

      Mike Whittaker - 2007-04-12

      Despite what you say, my installed Padwalker is not recognised, and I get a warning message when starting the debugger: "The procedure entry point Perl_Icomppad_ptr could not be located in the [dll] perl58.dll"

      This results in the displayed message in the Variables window: "Error - Install PadWalker Perl module to see local variables"

      Eclipse Version: 3.1.1 [IBM version using J9 compiler]
      Build id: M20050929-0840
      (fully updated)

      EPIC 0.5.33
      (fully updated)

      • Jan Ploski

        Jan Ploski - 2007-04-12

        Which version of ActiveState Perl do you have?

        • ch46

          ch46 - 2007-05-19


          I have the same problem.  I have ActiveState ActivePerl installed, and I used ppm to install PadWalker 0.09.  The Debugger doesn't work.  May I know how to get it to work?  Thank you.

          Chang-Ping Hsiao

          Loading DB routines from version 1.28
          Editor support available.

          Enter h or `h h' for help, or `perldoc perldebug' for more help.

          main::(C:/Documents and Settings/ping/workspace/Perl Code/
          11:    my $options = GetOptions( "env=s" => \$env_name, );
            DB<1> printf $DB::OUT "%vd", $^V;
            DB<2> print $DB::OUT eval { require PadWalker; PadWalker->VERSION(0.08) }
            DB<3> .
          main::(C:/Documents and Settings/ping/workspace/Perl Code/
          11:    my $options = GetOptions( "env=s" => \$env_name, );
            DB<4> T
            DB<5> .
          main::(C:/Documents and Settings/ping/workspace/Perl Code/
          11:    my $options = GetOptions( "env=s" => \$env_name, );
            DB<6> ;{
          do '' unless defined &dumpvar_epic::dump_package_vars;

          my $savout = select($DB::OUT);

  • miriamgh

    miriamgh - 2012-01-28

    Hi guys - this thread looks pretty old - I hope you got it solved, since I have the same problem, and I hope you can help me.

    Here is my problem description:

    I have installed ActivePerl, and I would like to debug a Perl program using Eclipse and EPIC. I have installed Eclipse and EPIC, they look OK. (It's doing basic syntax checking on an example Perl program).
    I have used PPM to install PadWalker (since that's what they say is needed to use the step debugger).
    Now, in Eclipse, when I try to step through the program, I get the error: "Error: install PadWalker module to see local variables".
    In PPM, I notice that it had installed PadWalker in area: "site", while all other Perl modules are installed in area: "perl".
    For area: "site", @INC shows:  … …/Environments/Active Perl/site/lib
    and for area: "perl", @INC shows: … …/Environments/Active Perl/lib
    What should I do?
    My system: Windows 7 x64.

    Many thanks in advance
    Miriam G

  • Jan Ploski

    Jan Ploski - 2012-01-29

    Miriam, you didn't mention your version of EPIC. The 'testing' version is recommended for debugging. PadWalker installed into 'site' sounds ok. Here's how EPIC detects PadWalker (try this is in your debugged script, it should print the PadWalker's installed version number):

    print eval { require PadWalker; PadWalker->VERSION(0.08) };
  • James Drinkard

    James Drinkard - 2012-02-24

    I just installed the latest version of ActivePerl on both my workstation and home laptop.  I have eclipse indigo running on Windows 7 on both.  I used Eclipse Marketplace to install the EPIC plugin, then I opened a dos prompt, typed ppm, which opens up AcitvePerl's module utility.  I typed in PadWalker, selected it for install and everything got pulled in fine.  You have to have an internet connection to do this obviously.  After that I had to configure Eclipse to do the Perl launch configuration described in the EPIC user guide and everything worked fine.  That is after I got pointed to that section in the manual from another post on this forum.


Log in to post a comment.