Epic does not work on Linux amd64

Robert Key
  • Robert Key

    Robert Key - 2009-11-29

    Hi I have installed epic plugin (latest and testing) on debian linux am64. Nothing shows in the preferences menu. There is no perl perspective. If I click Help -> About Eclipse -> Installation details I see Eclipse and EPIC. It is there but does not work! I installed as per web instructions. Is epic supposed to work on amd64? I have tried eclipse, eclipse jee, eclipse pulsar different versions to latest. No luck. Help please.

  • Jan Ploski

    Jan Ploski - 2009-11-30

    EPIC doesn't contain any native code, so it should work on x64. I recall having had problems with stability of x64 Java+Eclipse (not EPIC), but it was a long time ago.

    You should check whether any errors appear during Eclipse startup in the error log (workspace/.metadata/.log).

  • Robert Key

    Robert Key - 2009-11-30

    Hi thanks for the reply. I think the problem may be I am using galileo
    SR1 on an amd64. I tried with ganymede (3.4.2) on an i386 and that was ok. I will download gaynmede for amd64 and try with that. Thanks for your help you are correct about the non native code.

  • Robert Key

    Robert Key - 2009-12-04

    The problem seems to be with eclipse galileo SR1 and Debian linux amd64 (testing). The install software dialog (in eclipse) does not repaint and appears as though it is not working. Could be an X windows issue. Even if one installs epic in this situation then the preferences window in eclipse does not show epic and there is no perl perspective. I installed gaynmede SR2 on the same linux amd64 and epic does install. There are problems with the mouse. Clicking on a 'next' button pushes the button in but nothing else. You have to also hit the 'enter' key to move to the next dialog. I suppose this is what happens when you use a 'testing' distribution.
    Rob Key


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks