EPIC can't find includes

Help
jpollack
2012-02-24
2013-05-20
  • jpollack

    jpollack - 2012-02-24

    Hello,

    So the problem I'm having is this : EPIC cannot find include files, even when those files are in the same folder as the one that is referencing them.  I've even set the Perl Include Path, all to no avail.

    Here's a screenshot of one of the source files :

    Here's the same shot, with the tooltip expanded for the line with the red X next to it:

    So, you'll see that the file it can't find (PipelineScripts/Pipeline/Id.pm) is in the very same folder as the file that we're looking at (PipelineScripts/Pipeline/Db.pm).  I even tried adding the PipelineScripts folder to the Perl Include Path, and it didn't do any good :

    Any idea what's going on?

    Thanks for taking a look!

     
  • Jan Ploski

    Jan Ploski - 2012-02-24

    You must add the project base path to the include path rather than the path that points to the "Pipeline" folder. As is, the package name is Pipeline::Id, so it looks for ${project_loc}/Pipeline/Pipeline/Id.pm, which doesn't exist.

    For extra portability, add "." to the "Perl Include Path" rather than the absolute path. All relative paths specified there are interpreted as project-relative.

     
  • jpollack

    jpollack - 2012-02-27

    Awesome!  Looks like this worked.  Thanks!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks