EPIC and Eclipse Juno

Help
bzvestey
2012-06-03
2013-05-20
  • bzvestey

    bzvestey - 2012-06-03

    Has anyone tried using EPIC with Eclipse Juno?  I am just starting using it and while i have not seen any issues, i was kinda wondering if anyone has had any issues?  Note i am using the test site to get EPIC and using Juno RC2.

     
  • Kim Steele

    Kim Steele - 2012-08-01

    I can't even get it to install.

     
  • Emile Semmes

    Emile Semmes - 2012-08-29

    I was able to successfully get it to work with Juno build 20120614-1722 (latest from eclipse.org as of this post) and ActiveState Perl for Windows 5.14.2. Make sure you follow everything in the FAQ (http://www.epic-ide.org/faq.php) including installing PadWalker and the patch if you're working on windows.

     
  • t-Legiaw

    t-Legiaw - 2012-08-30

    mmmhhh - on Linux  I had no luck with Juno build 20120614-1722. I tried a lot of stuff - but I am only getting a message saying

    Cannot complete the install because one or more required items could not be found.
      Software being installed: EPIC 0.6.35 (org.epic.feature.main.feature.group 0.6.35)
      Missing requirement: EPIC 0.6.35 (org.epic.feature.main.feature.group 0.6.35) requires 'org.eclipse.platform.feature.group [3.2.0,4.0.0)' but it could not be found

     
  • Lieven Hollevoet

    Running fine on Ubuntu 12.04 with Juno M20120914-1800 and EPIC 0.6.45

     
  • Ed Kolis

    Ed Kolis - 2012-10-29

    Works for me on Windows 7 and 8 with Juno 20121004-1855 and EPIC 0.5.46… wait, there's a newer version 0.6.45 out? How come Eclipse's Check for Updates can't find any updates? I'm having horrible problems with content assist - that's why I came to this forum! (Every time I type an open paren or brace, EPIC immediately inserts the close paren or brace right afterward, even if I'm in the middle of a line of code adding a brace I missed! E.g. I have $obj->name and I want to change it to $obj->{name} so I type the open curly brace and I get $obj->{}name… AAAARGH!)

     
  • Jan Ploski

    Jan Ploski - 2012-10-29

    1. Check for updates will only work within the branch - EPIC currently has a "stable" branch 0.5.x and a "testing" branch 0.6.x. If you want to upgrade to testing (which is recommended), you will have to do so manually by providing the correct update site in Eclipse (http://www.epic-ide.org/updates/testing)
    2. You can disable the (not so) smart typing feature through Preferences > EPIC > Editor.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks