Unable to view any variables while debugging in Eclipse EPIC

  • Naveen

    Naveen - 2014-02-20

    I am using EPIC 0.5.46 in Eclipse(Red Hat) 3.2 with Perl 5.16.1 with Padwalker installed in CentOS. Till yesterday i was able to see the vars properly while debugging but today it is not showing anything. But i dont know how sometimes it appears like flash and then again when i step through it disappears. i tried latest epic(0.6.53) also, but that does not display arrays so reverted back to stable 0.5.46.

    It displays error as follows:
    !STACK 0
    org.epic.debug.varparser.TokenVarParser$ParseException: expected token N missing @0
    at org.epic.debug.varparser.TokenVarParser.readVar(TokenVarParser.java:151)
    at org.epic.debug.varparser.TokenVarParser.readVars(TokenVarParser.java:190)
    at org.epic.debug.varparser.TokenVarParser.parseVars(TokenVarParser.java:38)
    at org.epic.debug.db.StackFrame.readTopFrameVars(StackFrame.java:405)
    at org.epic.debug.db.StackFrame.getVariables(StackFrame.java:226)
    at org.eclipse.debug.internal.ui.elements.adapters.StackFrameContentAdapter.getChildren(org.eclipse.debug.ui_3.2.1.v20060823.jar.so)
    at org.eclipse.debug.internal.ui.viewers.provisional.AsynchronousContentAdapter.computeChildren(org.eclipse.debug.ui_3.2.1.v20060823.jar.so)
    at org.eclipse.debug.internal.ui.viewers.provisional.AsynchronousContentAdapter$1.run(org.eclipse.debug.ui_3.2.1.v20060823.jar.so)
    at org.eclipse.core.internal.jobs.Worker.run(org.eclipse.core.jobs_3.2.0.v20060603.jar.so)
    !ENTRY org.epic.debug Error 0 Feb 19, 2014 21:15:42.884
    !MESSAGE An error occurred while parsing debugger variables; contents of the Variables view may be inaccurate. Failure caused by string: {syntax error at (eval 45)[/home/nlogacha/workspace4/.metadata/.plugins/org.epic.debug/perl5db.pl:732] line 8, at EOF
    Missing right curly or square bracket at (eval 45)[/home/nlogacha/workspace4/.metadata/.plugins/org.epic.debug/perl5db.pl:732] line 10, at end of line

    DB<39> Unmatched right curly bracket at (eval 46)[/home/nlogacha/workspace4/.metadata/.plugins/org.epic.debug/perl5db.pl:732] line 5, at end of line
    syntax error at (eval 46)[/home/nlogacha/workspace4/.metadata/.plugins/org.epic.debug/perl5db.pl:732] line 5, near ";

    i tried reading all possible solutions in google, sourceforge, epic.org.. but nothing works, confuses me more.. 1.5 days i am trying to fix the same thing, but couldnt. Please help if anyone have any ideas. Thank you


  • Jan Ploski

    Jan Ploski - 2014-02-20

    0.6.x "does not display arrays" - huh? It works fine for me, and you should be using it, too. Maybe you have "Show Global Variables" / "Show Local Variables" disabled?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks