Using Module in external path

Help
2013-07-12
2013-07-12
  • Shaon Yousuf

    Shaon Yousuf - 2013-07-12

    Hi,

    Im trying to source a file into the project using the Shell::Source CPAN module. However, when Im trying to include the module in my code using the following command "use Shell::Source;" I get an error saying that the @INC variable does not contain the module. I installed the module Shell::Source; in a custom location and trying to include the custom path in the @INC variable but I cannot find where I can edit the @INC variable. The EPIC documentation says "To add entries to a project’s Perl Include Path (@INC), right click on the project icon and select Properties...." but I cannot see or find the Perl include path option there. The only options I see in the project property window are: resources, builders, project references, etc..". I am using EPIC 0.6.52. I added a snapshot of the project property window. Please help.

    Thanks

    Shaon

     
    Last edit: Shaon Yousuf 2013-07-12
  • Jan Ploski

    Jan Ploski - 2013-07-12

    Your project is most probably missing "Perl Nature". Right-click on project "Add Perl Nature".

     
  • Shaon Yousuf

    Shaon Yousuf - 2013-07-12

    Got it! Thanks so much!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks