*.T file extension

Help
2007-08-24
2013-05-20
  • Robert Futrell
    Robert Futrell
    2007-08-24

    Hello,

    We have a Perl project that contains some files with the extension ".t".  These files are our own format, specific to our project, and are not Perl scripts.  However, EPIC seems to think they are, and we get errors in our Error Logs for these files as a result.

    Perhaps I'm having an off day, but I cannot figure out how to tell EPIC to ignore these files (e.g., not run the Perl syntax checker over them).  I tried changing the default editor for *.T files from EPIC to the standard text editor, but it appears the Perl syntax checker is still running over them.

    Any ideas?  Also, I've never heard of *.t as being an extension for Perl scripts.  What is this extension commonly used for?

    Thanks

     
    • Manni
      Manni
      2007-08-24

      Can't help you there, but:

      "Also, I've never heard of *.t as being an extension for Perl scripts. What is this extension commonly used for?"

      For tests. Nearly every module on CPAN comes with a couple of test scripts and all of them have the .t extension.

      Regards,
      Manni

       
    • Johan Vromans
      Johan Vromans
      2007-08-24

      See Preferences -> General -> Editors -> File associations.
      Here you can change the standard association.

       
    • Jan Ploski
      Jan Ploski
      2007-08-24

      Go to Preferences/Editors/File Associations and configure Eclipse's built-in text editor to be the default editor for *.t (rather than EPIC). Perform a Clean on the project, this should remove the markers from *.t files. However, some remaining markers might be left on the folders, which you will have to remove surgically. That is, close Eclipse, then visit workspace/.metadata/.plugins/org.eclipse.core.resources/.projects/YourProjectName and remove the file .markers. Restart and do project clean again.

       
    • Robert Futrell
      Robert Futrell
      2007-08-24

      Thanks everyone for the suggestions!

      I now know what *.t files are for as far as Perl is concerned.  I wasn't aware CPAN modules often came with tests with this extension (I usually use just the built-in Perl stuff in my work).

      I tried changing the associated editor from Perl to the default (text) editor, but all that did was get rid of syntax highlighting; the *.t files were still scanned and error markers applied to them.

      jploski's solution worked for me.  I did a Clean of the project and rebuilt, but the error markers on the *.T files were still there.  I then shut down Eclipse, deleted the ".marker" files for my project, restarted, and did another clean/rebuild.  Viola, the *.T files are now ignored!

      Thanks