Problems using Debugger (PadWalker)

Help
2004-07-15
2013-05-20
  • Ralf Heydenreich

    Hi all,
    I've just installed EPIC (new version 0.3.0) and wanted to start a debugging session. But all I got was the following message:

    Error Parsing Debugger Variables
      *******************************
      *******************************
      +++++++Error Parsing Vars++++++
      *******************************
      *******************************
      Can't load 'C:/Perl/site/lib/auto/PadWalker/PadWalker.dll' for module PadWalker: load_file:procedure not found at C:/Perl/lib/DynaLoader.pm line 229.
       at C:/Perl/lib/perl5db.pl line 984
      Compilation failed in require at C:/Perl/lib/perl5db.pl line 984.
      -------------------------------
      -------------------------------
      +++++++Error Parsing Vars++++++
      -------------------------------
      -------------------------------

    My Perl version:

    This is perl, v5.8.0 built for MSWin32-x86-multi-thread
    (with 1 registered patch, see perl -V for more detail)

    How can I fix this behaviour? PadWalker is installed and in the given path.

    TIA,
    Ralf.

     
    • dagmar

      dagmar - 2004-07-15

      Hi,
      I've got exactly the same environment and exact the same error messages! Anyone out there who knows to fix this?
      Thanx
      Dagmar

       
      • pstahle

        pstahle - 2005-03-10

        I found this thread while searching the forums for the problem I am having.
          I am running on debian linux
          have PadWalker 1.0 installed
          using Perl v 5.8.4

        And I am not able to see variables defined with my...

        Is this still a problem? Does anyone have a fix?

        Thanks,
        Patrick

         
    • Gerald Talton

      Gerald Talton - 2004-07-15

      I just got this same exact error and I have the same version of Perl. Can someone please tell me how to fix this?

      -Gerald

       
    • Jochen Ruehl

      Jochen Ruehl - 2004-07-15

      Hi,

      From a closed bug report:
      "The PadWalker module provided by ActiveState does not work with Perl 5.8.X on windows systems. Use the PadWalker module from the Epic site. (this is also mentioned in the online help)."

      Here is the URL:
      http://e-p-i-c.sourceforge.net/downloads/padwalker_010_Perl5_8.zip

      Bye
      Jochen

       
    • dagmar

      dagmar - 2004-07-15

      Hi,
      I'm sorry, but I get that error with this version of PadWalker!

      -Dagmar

       
    • Stephan Ruehl

      Stephan Ruehl - 2004-07-15

      I have tested the PadWalker module provided on the EPIC Page with ActiveState Perl 5.8.2 and 5.8.3 and it works fine.
      PadWalker 0.10 has been adjusted to Perl version 5.8.1 and above. So you might either switch to Perl version >5.8.1  or compile PadWalker 0.9 for yourself.
      If that is no feasible for you, I might provide a binary version of PadWalker 0.9 (if I can find the time).
      just let me know ..

      Stephan

       
      • Stephan Ruehl

        Stephan Ruehl - 2004-07-16

        A PadWalker version suitable for Perl 5.8.0 is now available from the EPIC download site.
        This should fix the problem ...

        Stephan

         
    • Gerald Talton

      Gerald Talton - 2004-07-16

      Shameless double post but I'm getting the same error on Cygwin AND AS Perl.

      My code:

      my $var1 = "hello";

      when shown in the variable window is

      $var1 = ->*DB::single = ...

      I installed PadWalker 0.10 from the web site on a fresh AS Perl 5.8.3 install.

      Any help is appreciated. :)

      -Gerald 

       
      • Stephan Ruehl

        Stephan Ruehl - 2004-07-16

        This is known bug with PadWalker 0.10 not a problem of  EPIC. See the EPIC User's Guide, section Known Bugs & Problems for a work around.

        Stephan

         
    • Anonymous - 2004-08-09

      "Error Parsing Debugger Variables" problem with perl 5.8.3 under GNU/Linux.

      However I noticed it only happens during instanciation of objects of derived classes.

       
    • Stephan Ruehl

      Stephan Ruehl - 2004-08-14

      Could you send me the relevant part of  your code, so that I can fix the problem ?

      Thanks

      Stephan

       
    • George

      George - 2005-03-30

      I am having the same issue as the original poster.

      I have tried using 5.8.6, 5.8.4 and 5.8.3.  All have this issue.
      I am using the 5.8.1 version of padwalker.

      Any ideas?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks