editor wrapping throws off line numbers

Help
2007-10-15
2013-05-20
  • Wanda_B_Anon

    Wanda_B_Anon - 2007-10-15

    Recently my editor window went a little whacky.  There is now no bottom horizontal scroll bar, and wrapping  of long lines throws off the line numbering. How do I set things so I can have long lines, and the bottom horizontal scroll bar reappears, and lines do not wrap when I don't want it? 

    If there was a way to post images, I could show you, but here is a test text to put into the editor window: This is basically 4 lines, comment, print, comment, print.  The editor says it is four lines in the count on the left, but depending on the size of the window, it could look like a lot more, and numbering does not line up....

    sorry this threading software wraps...

    #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
    print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50\n";
    # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
    print "Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50\n";

    This should look like: (with line numbers displayed...)

    1 #  1 2 3 4 5 6 7 8 9...
    2 print "Hello World.\n  1 2 3...
    3 #  1 2 3 4 5 6 7 8 9...
    4 print "Goodby cruel World.\n  1 2 3...

    For example, it can look like this in my editor: (it wraps, but the 1-4 line numbers do not line up.)

    1 #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
    2 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
    3 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
    4 print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 11
       12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
       28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
       44 45 46 47 48 49 50\n";
       # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
       19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
       35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
       print "Good-by cruel World.\n  1 2 3 4 5 6 7 8 9
       10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
       26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
       42 43 44 45 46 47 48 49 50\n";

    Eclipse Version: 3.3.1
    Build id: M20070921-1145
    Epic Source 0.6.16
    Epic Perl Editor 0.6.9
    Windows XP version 5.1

    Thanks for any suggestions.

     
    • Wanda_B_Anon

      Wanda_B_Anon - 2007-10-15

      Answering my own question, turn off the word wrapping in Window->Preferences...->Perl Epic->Editor.  And watch out for precedence of line numbering with Window->Preferences...->General->Editors->Text Editors.

      Though I am happy to hear if anyone can add to this.

      ~ June 2006 info on word-wrap difficulties:

      http://www.eclipsezone.com/eclipse/forums/t74384.html

      http://ahtik.com/blog/eclipse-word-wrap/

       
      • Wanda_B_Anon

        Wanda_B_Anon - 2007-10-15

        I take it back, things still suck.  They suck when your lines are wrappable, whether or not you wrap them.  Try with the 24 lines of long lines below.  Open and close the file, shrink and expand the window, etc.  It wraps when it should not, won't display line numbers when it should, etc.

        There seem to be 2 places to turn on line numbers, and I do not see how they interact.

        In Window->Preferences...->Perl Epic->Editor, turn off wrapping and line numbers.
        In Window->Preferences...->General->Editors->Text Editors, turn off line numbers.

        There is one place for wrapping, but I sure do not know how it works between
        already open files and window adjusts, and newly opened files in small windows.

        Enough to drive you crazy.

        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 1 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 2 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 3 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 4 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 5 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        #  1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
        print "Hello World.\n  1 2 3 4 5 6 7 8 9 10 \n";
        # 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 
        print " 6 Good-by cruel World.\n  1 2 3 4 5 6 7 8 9 10 \n";

         
        • Manni

          Manni - 2007-10-17

          Is anyone else having difficulties disabling line wrapping permanently?

          Currently, my Eclipse tells me that line wrapping is off, but lines are wrapped nevertheless. I have to first enabled wrapping and then disable it to see any effect. But this effect is gone as soon as I reopen the file (I don't even have to restart Eclipse to lose the setting).

          Regards,
          Manni

           
    • forkdeath

      forkdeath - 2007-10-16

      Ditto, I have the same issue.  I think it was the last EPIC update that did it.

       
    • Jan Ploski

      Jan Ploski - 2007-10-18

      This was a bug introduced in 0.6.16, now fixed in 0.6.17.

      Please remember for the future that you can easily downgrade EPIC: Help / Manage Configuration / Click on "Show disabled features" - disable the current version, enable an older one and restart Eclipse to downgrade. Of course, reporting a problem (like you did) before the "emergency downgrade" is great.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks