Timed out while waiting for Perl debugger ...

  • Adrian Diezig

    Adrian Diezig - 2008-12-26

    My installation:
    WinXP SP3
    Eclipse Platform: 3.4.1
    EPIC: 05.46
    Perl: 5.8.8 824

    When I try to debug a perl script after a while everytime a box with the following text appears:
    "Timed out while waiting for Perl debugger connection"

    Debugging is not possible.

    • Jan Ploski

      Jan Ploski - 2008-12-27

      This could be a firewall problem. Perl makes connections to localhost in port range 5000-5004 (or above, depending on the number of active debugging sessions).

    • Steve Hodapp

      Steve Hodapp - 2009-01-07

      I'm a new EPIC user and experiencing the same problem on a Dell Vista PC except I can debug for a while after restarting the PC until it starts timing out again.  I'm using two other XP PC's that do not have this problem so I thought it might be a Vista specific issue until I saw this post.

      • Jan Ploski

        Jan Ploski - 2009-01-08

        I just tested in Vista and couldn't reproduce the problem. Does this happen during script or CGI debugging? Do you terminate your debug sessions using the Debug view? Does the output of "netstat -an" (from command prompt) grow without bounds (some number of TIME_WAIT entries for port 5000-5004 is ok there, but they should go away with time; also, when a debugger session is closed there should be no ESTABLISHED connections on these ports)?

        • Anonymous

          Anonymous - 2009-03-17

          I have a related problem involving the ActiveState debugger window.  I'm still debugging but maybe you already know the answer or can suggest some debugging steps.

          I have 2 installations.  In one, debugging works properly.  In another, when I click on the bug, the ActiveState Debugger opens a new window and I can step through the program in that window (but no breakpoints).  When the program terminates, the ActiveState debugger window closes and a small error window is open saying EPIC Error: Timed out while waiting for Perl debugger connection". 

          While debugging in the ActiveState Debugger window, variables/values are shown in that window but not in the Eclipse Variables panel.  The Debugger panel in Eclipse shows a debugging session.

          In Window - Preferences - Perl Epic, I have tried pointing the debugger explicitly at perl.exe in the directory where I installed ActiveState Perl (although the default configuration works fine in the other installation).  No improvement.

          I have used netstat on the system that works and can see the path established.  I haven't tried it yet on the not-working installation--hope to do that tonight.  I assume the connection is not being made, as the timeout message suggests.

          I'm clueless as to why the ActiveState debugger window opens.

          • Jan Ploski

            Jan Ploski - 2009-03-17

            EPIC expects "perl -d" to be the native command-line debugger, not some replacement. So you definitely want to disable the ActiveState debugger if you wish to debug with EPIC.

            Maybe this helps:


    • Steve Hodapp

      Steve Hodapp - 2009-01-08

      Thanks for your reply.  I'm just learning Perl so these are simple scripts only.  I'll monitor the port status with the "netstat -an" command and post what I observe.  The Vista machine is a home machine so it my be a few days before I can gather the information.  There have probably been some instances where I've neglected to terinate some of the debug sessions from the debug view and ultimately exited Eclipse from the "Perl" view.  Thanks again for your help, Steve.

    • Steve Hodapp

      Steve Hodapp - 2009-01-19

      I haven't experienced the port time out or slow debugger starts since my previous post.  Ports 5000 and up appeared to behave as described by Jan.  I'll post what I see on the ports when and if I see the problem again.


Log in to post a comment.