EPIC 0.3.10 and Eclipse 3.1M7

  • Adalbert

    Adalbert - 2005-05-20

    Does anyone have tried to install and use the most recent EPIC (0.3.10) in Eclipse 3.1M7?

    I installed the plugin but the editor does not work. Whenever I double click on a Perl file a popup window:

    An error has occurred. See error log for more details.

    In the .log file I find a

    java.lang.NoClassDefFoundError: cbg/editor/ColoringSourceViewerConfiguration

    message. In the preferences for Perl EPIC the subsections "Editor" and "Templates" generate the same error when being selected.

    I do not really understand the problem because the missing class seems to exist in the file editor.jar which is contained in the file org.epic.ext.cbg.editor_0.3.1.jar.

    Any hints would be welcome!



    • LeO

      LeO - 2005-05-23

      It works fine on my M7. I guess this is some well known problem of missing jar. I don't know what the final resolution was resp. where the root of the Error could be found. But I guess some people solved it by deleting and again install. Don't know if this helps, but on my machine it works fine.

      • Adalbert

        Adalbert - 2005-05-23

        Hmm, my installation directory structure is as follows:


        In the above mentioned directory ../eclipse there is a sub-directory "links":


        The file ".link.EPIC" has these contents:




        The EPIC data is stored. Among these data there is a file


        This .jar files contains (among other data) the file "editor.jar".

        And this file ("editor.jar") contains the classfile of the class


        Do you see any failure in the file/directory structure?

        Thanks in advance,


    • jason scripte

      jason scripte - 2005-05-25

      I ran into this too.  The jars that are on the EPIC update site can't be installed by just dropping them in the plugins directory (this seems to be what causes the problem, as that's how I how tried to install it since M7 now supports jared plugins).  I was able to successfully install and use EPIC using the update site via Help | Software Updates in Eclipse.  Ultimately, I think Eclipse extracts the jars into their own directories in the plugin directory.  You might want to try extracting each EPIC jar into its own directory and putting those directories in the plugin directory and see what happens (if you really want to avoid using the software updates feature built into Eclipse).

    • Adalbert

      Adalbert - 2005-05-31

      I added the URL http://e-p-i-c.sf.net/updates/testing as a new update site and then tried to install EPIC from there but I got a popup window with the message:

      No features found on the selected site(s). Choose a different site or site category. What am I doing wrong?



      • Terry Lemons

        Terry Lemons - 2005-05-31

        Hi Adalbert

        I just removed EPIC from my Eclipse environment, then added it back.  I used Help -> Software Updates -> Find and Install ... -> Search for new features to install.   I clicked on 'New Remote Site...', and added http://e-p-i-c.sf.net/updates/testing as the 'URL' value in the 'New Update Site' dialog box.  I clicked OK to that box, and then Next in the Install dialog box.  It all just worked.

        You might want to try removing EPIC, and re-applying it.

        Hope this helps.

    • jason scripte

      jason scripte - 2005-06-06

      I keep running across an issue where after I check a file into CVS and I try to modify that file without closing it, I get an error message that says: "Save could not be completed.  Reason: Has been changed on the file system."  I don't remember seeing this in earlier versions of Eclipse, so I'm not sure if it is an incompatibility with EPIC or a bug introduced recently in Eclipse (though, I haven't noticed this issue with other editors, such as the C++ one from CDT).

      By the way, I am now running Eclipse 3.1RC1.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks