shift+tab not working in perl editor?

2009-12-23
2013-05-20
  • Piotr Dobrogost

    Piotr Dobrogost - 2009-12-23

    Hi

    It seems perl editor does not handle shift+tab (unindent operation). 
    Is there any way to overcome this?

     
  • Jan Ploski

    Jan Ploski - 2009-12-23

    I think it works, but it might have some trouble in cases where tab characters and spaces are mixed within the block to be unindented. Or perhaps it depends on the indentation settings (whether to use space or tab, and how many spaces). In any case, do upgrade to the latest version of 'testing' before experimenting.

     
  • Anonymous - 2009-12-24

    I encountered this exact same problem.  I just downloaded EPIC last night for the first time ever (great plugin btw) but I can't un-indent using shift-tab.  I can't figure out how to get it to work, I've tried everything.  For Java programs it works fine. 

    When I look at the whitespace characters, I see spaces-only.  I tried changing it to using tabs but that doesn't seem to work, although I'm not sure exactly which setting to change, there appears to be many such settings throughout Eclipse.

     
  • Jan Ploski

    Jan Ploski - 2009-12-25

    I just checked that it works for me with the following configuration (in Preferences > Perl EPIC > Editor):
    - Displayed tab width: 4
    - Insert tabs/spaces on indent: 4
    - Use spaces instead of tabs

    The version of EPIC is 0.6.35. It works when the block to be unindented contains 4 spaces as indent in all lines. It also works when it contains tabs as indent in all lines. It does *not* work if the block contains at least one line which begins with a space followed by a tab.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks