Timed out while waiting for perl debugger con

toni
2010-01-22
2013-05-20
  • toni

    toni - 2010-01-22

    Hi,

    I am using
    Perl : v5.10.0 built for MSWin32-x86-multi-thread
    EPIC: 0.6.35
    Perl5db : 1.30
    Eclipse : 3.2
    on windows xp sp3

    I am trying to debug as simple perl code but while doing so i am getting the following error
    message " EPIC ERROR : Timed out while waiting for perl debugger connection"
    and also getting the following warning in the console
    Use of uninitialized value in subroutine dereference at (null) line 1.
    perl5db.pl did not return a true value.
    BEGIN failed-compilation aborted.

    Please help me solve this error

    Thanks

     
  • Jan Ploski

    Jan Ploski - 2010-01-22

    Does it work with the current version of Eclipse?

     
  • toni

    toni - 2010-01-23

    I don't know as i didn't give a try at it. Does it have anything to do with eclipse version?

     
  • Jan Ploski

    Jan Ploski - 2010-01-23

    Possibly. You should find out by trying.

     
  • toni

    toni - 2010-01-25

    I have tried it on eclipse 3.3 also but there wasn't any success, still the same error.

     
  • Edvin Pehlivanovic

    Try to include the path to perl5db.pl (Perl\lib directory) to the Perl Include Path to your project.
    (Project->Properties->Perl Include Path)

    This works for me.

     
  • Tony Byers

    Tony Byers - 2010-03-30

    Hi,

    Did you get an answer to this? I've got exactly the same problem:

    Windows 7 64-bit
    Active State Perl 64-bit 5.10.1 build 1007
    Eclipse 64-bit 3.5.0 Build I20090611-1540
    Pad walker 1.9
    Java 1.6.0_18 64-bit
    EPID seems to run ok but the debugger doesn't

    Thanks

     
  • Tony Byers

    Tony Byers - 2010-04-02

    Thanks for pointing me in the right direction. All working now.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks