#509 Cannot install EPIC with Eclipse 3.4

open
nobody
None
5
2008-09-01
2008-09-01
Anonymous
No

I downloaded Eclipse 3.4 for Java, then I tried to install EPIC 0.6.25 (from http://www.epic-ide.org/updates/testing\)(and other versions also) it returned:

Cannot complete the request. See the details.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.

Discussion

  • Jan Ploski

    Jan Ploski - 2008-09-02

    Logged In: YES
    user_id=86907
    Originator: NO

    Delete org.epic.* from eclipse/features and eclipse/plugins and restart Eclipse. Then try installing again.

     
  • dmattes

    dmattes - 2008-09-04

    Logged In: YES
    user_id=1190231
    Originator: NO

    I got the same error, but the following worked for me (with Eclipse 3.4 SDK)

    1.
    Window -> Preferences -> General -> Capabilities
    Enable "Classic Update"

    2.
    Help -> Software Updates -> Find an Install
    Install Epic now by the "old" way of Eclipse

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks