#14 perl include path does not work

v0.1.0
closed-fixed
None
5
2003-06-16
2003-05-20
Arne Bernin
No

When i set an include path (browse file and press add
to list) for a perl project and go out with "ok", the
path is lost.

I use the perl plugin version from 20030520...

Discussion

  • Jochen Ruehl

    Jochen Ruehl - 2003-05-21

    Logged In: YES
    user_id=274815

    Could you please start eclipse from the command line (on Windows please
    add -debug parameter) and have a look if exceptions occur on the console
    while setting the include path.

     
  • Jochen Ruehl

    Jochen Ruehl - 2003-05-21
    • milestone: --> v0.1.0
    • assigned_to: nobody --> luelljoc
     
  • Jochen Ruehl

    Jochen Ruehl - 2003-05-27

    Logged In: YES
    user_id=274815

    Could you please add the following line to the file
    plugins/org.epic.perleditor_0.1.0/plugin.xml in the <requires> </requires>
    section:

    <import plugin="org.apache.xerces"/>

    and restart eclipse.

    This is necessary if you are using JDK 1.3.x

     
  • Jochen Ruehl

    Jochen Ruehl - 2003-06-16
    • status: open --> open-fixed
     
  • Jochen Ruehl

    Jochen Ruehl - 2003-06-16
    • status: open-fixed --> closed-fixed
     
  • Juergen Hemelt

    Juergen Hemelt - 2003-11-04

    Logged In: YES
    user_id=864845

    Hi,
    I have the same problem using JRE 1.3. With -debug option I
    get the following output:

    Parsed Syntax File perl.xml
    org.jdom.JDOMException: Error in building:
    org.apache.xerces.parsers.SAXParser
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:306)
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:617)
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:599)
    at org.epic.core.util.XMLUtilities.getIncludeEntries
    (XMLUtilities.java:51)
    at
    org.epic.perleditor.editors.util.PerlExecutableUtilities.getPerlExe
    cutableCommandLine(PerlExecutableUtilities.java:130)
    at
    org.epic.perleditor.editors.util.PerlExecutableUtilities.getPerlExe
    cutableCommandLine(PerlExecutableUtilities.java:41)
    at
    org.epic.perleditor.editors.PerlSyntaxValidationThread.validate
    Syntax(PerlSyntaxValidationThread.java:161)
    at
    org.epic.perleditor.editors.PerlSyntaxValidationThread.run
    (PerlSyntaxValidationThread.java:128) Root cause:
    java.lang.ClassCastException:
    org.apache.xerces.parsers.SAXParser at
    org.jdom.input.SAXBuilder.createParser(SAXBuilder.java:392)
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:283)
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:617)
    at org.jdom.input.SAXBuilder.build(SAXBuilder.java:599)
    at org.epic.core.util.XMLUtilities.getIncludeEntries
    (XMLUtilities.java:51)
    at
    org.epic.perleditor.editors.util.PerlExecutableUtilities.getPerlExe
    cutableCommandLine(PerlExecutableUtilities.java:130)
    at
    org.epic.perleditor.editors.util.PerlExecutableUtilities.getPerlExe
    cutableCommandLine(PerlExecutableUtilities.java:41)
    at
    org.epic.perleditor.editors.PerlSyntaxValidationThread.validate
    Syntax(PerlSyntaxValidationThread.java:161)
    at
    org.epic.perleditor.editors.PerlSyntaxValidationThread.run
    (PerlSyntaxValidationThread.java:128)

    Rgds,
    Juergen

     
  • Jochen Ruehl

    Jochen Ruehl - 2003-11-04

    Logged In: YES
    user_id=274815

    There seems to a problem with Java <1.4.
    Please use Java 1.4.x for the time being.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks