Crashed System

  • Anonymous - 2014-05-31

    I was trying to get Disciples 2 running in dxwnd, not only did it fail on default settings but when I used the "simulate 16BPP" & "DirectX 8" options it crashed the system entirely (directly to bios, no bluescreen or error message).

    Win8.1 Update 1, Nvidia 650M driver 337.88

  • gho

    gho - 2014-06-01

    I'm sorry for the inconvenience, but, believe me, if I were able to develop a program able to crash a PC to the root of BIOS, I would be the king of hackers.
    Anyway, I'm trying to handle my copy of Disciples II (it's a wonderful Disciples II Gold Edition in 8 CD!) and I see that the game shows problems (it doesn't start) and, sadly, in a sophisticated way. Please, stay tuned for news: it seems that there are interventions needed before DxWnd will be able to manage this wonderful game.


    Disciples II now working on my Win7 PC: it has nothing to deal with DirectX 8, it seems to use the older previous reseases and DxWnd must be configured in DirectX1-6 mode. Also, there are problems hooking "dwmapi.dll", but you can avoid this sort of problems by unchecking the "Hook all DLL" flag. To make things simpler, I'm posting here an export configuration file for the game: you can import it and change the game path according to your installation path. I hope that this way it could work also on Win8.

    Last edit: gho 2014-06-01
    • Taiyoumaru

      Taiyoumaru - 2014-12-06

      Greetings and thank you for the awesome program. I am having some difficulty getting this to work with Disciples 2 Gallean's Return. I am running on Windows 7 64 Ultimate.

      As you know, D2 Gold contains both Gallean's Return (Dark Prophecy, Guardians of the Light and Servants of the Dark) and Rise of the Elves, which is standalone. Each comes with 2 installations and configuration executable. Within both configuration executables it is possible to set options like resolution (800x600, 1024x768, 1280x1024), Run in Window Mode, Use Direct3D, Stretch to fullscreen and some others.

      Whenever I tried to run Rise of the Elves in a window using the setup options, it would work just fine. But using the same options in Gallean's Return is not possible because unlike RotE which is compatible with 32bit desktop colors when using Direct3D mode, Gallean's Return does not initialize with Direct3D mode on, and the other option is to set my monitor to 16bit color depth, which also disables Aero and looks horrible. I also tried faking or forcing 16bit from the DxWnd options but that didn't work.

      I have a second 1280x1024 max resolution monitor that I want to run Disciples 2 on. What I am looking for is a way to run this game at 800x600 game resolution but stretched to a 1280x1024 window. I am also looking for a way for the game to not go black when it is not in focus, maybe only mute the sounds.

      Is it possible with DxWnd? Thank you kindly for your help.

      edit: I am using V2_03_02_build and also tried your file but that didn't work either, the game always launches in fullscreen unless I set it to window mode from the configuration file and switch 16bit color.

      Last edit: Taiyoumaru 2014-12-06
      • ivdok

        ivdok - 2014-12-06

        I have a second 1280x1024 max resolution monitor that I want to run Disciples 2 on. What I am looking for is a way to run this game at 800x600 game resolution but stretched to a 1280x1024 window. I am also looking for a way for the game to not go black when it is not in focus, maybe only mute the sounds.

        Is it possible with DxWnd? Thank you kindly for your help.

        I second this. That would be great, because all consumer virtualization software I tried so far does not respect Windows resolution change action - leaving only black "funeral" outline and content in the center of screen, which is NOT good in my opinion. And I have no other decent choices - Wine can't handle some stubborn games (with all due respect, 95% of games I play work with it), even Windows itself can't (I don't blame dev team - maintaining legacy code and structural flaws within it is heroic and ungrateful job - nobody notices if their 20yo old program works, but if it doesn't, everybody loses their mind), and I can't really change my OS - XP is already performing worse than Vista+ with my rig (I tried, trust me), and 9x is completely impossible doe to missing essential drivers. I dual-boot into windows from time to time, because AMD drivers, Wine and Assassin's Creed don't go well together. But I'm still out of choices. Right now there's no stretching. At least working one.

        Last edit: ivdok 2014-12-06
        • Anonymous - 2014-12-07

          In this case you can use Dxwnd simultaneously with GameCompanion, so the window will be stretched to fill the entire height & width of your screen, but it still running on Windowed mode (Fake fullscreen). Very nice combo right! :p

          Download GameCompanion here:


  • Taiyoumaru

    Taiyoumaru - 2014-12-07

    Thanks for the link, I tried the program but sadly neither it nor DxWnd can force it into windowmode, I'm sure I specified somewhere, but I have only managed to make it run in window mode when I select window mode from the configuration executable (first setting my display to 16 colors which is NOT desirable). I need a way to force it into window mode without firstly changing color depth, because this also disables Aero, which is also undesirable.

    • Anonymous - 2014-12-07

      Sorry to hear about that. GameCompanion only work with the game already running on Windowed Mode, so it mean Dxwnd must work with the game too...

      Just waiting for gho to come back, everything will be fine soon!

  • aqrit

    aqrit - 2014-12-07


    DirectX->Emulation->Primary Surface
    ( keeps 32bpp desktop + aero on here )

    You can select the stretched 1280x1024 resolution
    in Main->Position->"Window Initial Position & Size" with "X,Y Coords"
    ( select the 800x600 in-game )
    you may also want to enable the bilinear filtering for the stretcher...

    If you click the "Disciples II" icon on the taskbar then Discipl2 will continue rendering without focus while you do others things on the desktop

    have fun!

  • Taiyoumaru

    Taiyoumaru - 2014-12-07

    Utilizing the above settings I still cannot get DxWnd to force the game in window mode. Here is a my configuration file as well as a screenshot of the game's setup, perhaps I'm doing something wrong. But the problem persists with Gallean's Return.

    edit: after trying the above settings in Rise of the Elves, where I set the game to run in a window from the setup, DxWnd also does not resize the window to 1280x1024 even with X,Y Coords selected 50/50/1280/1024.

    Last edit: Taiyoumaru 2014-12-07
  • aqrit

    aqrit - 2014-12-07

    sorry for the late reply, was in "static mode"

    attached works for me on win7

    I believe the problem was in your dxw file but I've
    also include the default 'Disciple.ini' file

  • Taiyoumaru

    Taiyoumaru - 2014-12-08

    3rd time trying to post a thank you, so Thank you! Your file worked perfectly. I thought "path" meant just the path and not having the actual exe selected and launch was meant for the exe. Bit confusing for new users, some small tooltips over each option would definitely help a ton.

    I then proceed to move it to my second monitor, maximize it and then eliminate the title bar with the _ [] X using Shiftwindow. Does DxWnd have any way of automating these 3 steps as well? Thanks again, you saved me precious gaming time!

    • gho

      gho - 2014-12-08

      You can eliminate the title bar by selecting the Video "modal style" option.
      Coordinates are adapted to the primary screen by selecting the "Desktop" position in the main tab. Currently there's no way to automatically adapt to the second monitor, but it's an idea ....


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks