wan3 - 2010-01-28

I did a multi volume backup on different files (volumes) on different hard drives
I have to restore the volume1 file /mnt/backup/sdb3-level2-091212.dump001
and the volume2 file /mnt/backup/sdb3-level2-091212.dump002

The problem is that the volume 1 file is empty (length zero) and restore exits with a tape read error.

I have to skip this file to restore the rest of the backup.

I tried to restore with using the -M option for multiple volume backup

restore -RMf  /mnt/backup/sdb3-level2-091212.dump -s 2
I get the error message: rmtioctl MTFSF: Inappropriate ioctl for device
So  I think the option -s 2 to switch to the second volume is not working for files
I even tried to set the environment variable RMT but I could not get restore not
to call rmt. And I think rmt is what makes the above error.

I also tried the -R option to restart an interupted restore

restore -Rf /mnt/backup/sdb3-level2-091212.dump002

I get
Mount tape volume 1
Enter ``none'' if there are no more tapes
otherwise enter tape name (default: /mnt/backup/sdb3-level2-091212.dump002)
I tiped in /mnt/backup7/sdb10-l7-091008.dump002
I got
Wrong volume (2)
Mount tape volume 1

So restore insists on mounting volume1

There must be a way to skip lost tapes for sure ?????