restore not finding subsequent tracks on DAT?

Help
2000-05-17
2013-05-20
  • Martin von Weissenberg

    Hello!

    I have a problem with dump/restore that's possibly related to my way of using dump. I'm responsible for two mission-critical servers and need to get backup schemes running as soon as possible. I would appreciate any kind of assistance here, including real-life examples.

    The problem is as follows, and is replicable on both machines: I have several filesystems that I want to dump to a SCSI DAT drive. I use several sequential dump commands to write the filesystems to /dev/nst0:

    /sbin/dump -0u -B 12000000 -f /dev/nst0 -b 64 /; /sbin/dump -0u -B 12000000 -f /dev/nst0 -b 64 /usr; ...

    ... etc for all the filesystems. All these dump commands succeed without errors and I can find the tracks on the tape using mt. However, when I try to verify the dumps using restore, it verifies the first track, then stops and asks me to find the second filesystem. I don't have access to the error message right now, but it says something about replacing the tape and asks me to press enter when done. Now, the next filesystem is on the next track, right under the nose of restore; one would assume that pressing enter would be enough. But restore can't find the second track, nor any subsequent tracks. I can't use mt to reposition the tape at the exact start of track 2 because restore hogs the device. I've tried both /dev/st0 and /dev/nst0, same problem. What am I doing wrong here?

    Both servers have a HP 12/24 SCSI DAT. The version of dump I'm using is 0.4b15; this is the standard rpm supplied with RH6.2. Please help; I've put been forced to do manual tar dumps for the last few weeks.

    --Martin

     
    • Martin von Weissenberg

      OK, the problem is solved. The trick is to manually reposition the tape with 'mt -f /dev/st0 rewind; mt -f /dev/st0 fsf 1' between the restore sessions. Took me only a few days to find out.

      Thanks for the... erm... huge amount of silence in this forum.

      --Martin

       
      • Stelian Pop

        Stelian Pop - 2000-05-28

        Oops, I was not monitoring the forum, so I didn't notice that some users
        used it :(

        But I'm glad you found yourself the solution to your problem. :)

        Stelian.

         
        • Kyle Wilson

          Kyle Wilson - 2004-12-02

          Martin,

          I have a somewhat similar problem, but I'm not sure I understand your solution.  I have some data which was dumped onto tape using 3rd party backup software.  Fortunately, the dump seems to be standard.  However, the 3rd party software put a small posix tar header at the top of each tape.  I can manually move the tape past the tar header on the first tape using mt, but I need to do the same for each subsequent tape.  Since I am using interactive restore, how can I run the mt command to prepare the second tape before I tell my interactive restore session to continue? 

          Kyle

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks