#126 Multiple errors when restoring level 1 dump

open
None
5
2007-09-21
2007-09-21
Bob Rogers
No

Restoring the level 0 dump onto our new server went without a hitch, but restoring the multivolume L1 dump on the new system encountered a number of odd problems. The partition is ext3 (in both cases). The attached transcript shows a "re-enactment" -- the first time through, restore segfaulted on the third and last volume, but I neglected to save the transcript. The L1 dumps were verified when they were made, and the MD5 checksums still match, so I do not suspect corruption of the L1 dumps.

The symptoms look suspiciously similar to the "[ 1165648 ] segfault restoring level 1 backup" issue, where resizing the partition was suspected. So I went through my notes, and am pretty sure that the partition was not resized between the level 0 and level 1 dumps, though it had been resized some time before.

Dump system software (SuSE 8.1 RPM versions):

dump-0.4b31-23
e2fsprogs-1.28-18
k_athlon-2.4.21-198
glibc-2.2.5-184
gcc-3.2-36

Restore system software (SuSE 10.1 RPM versions):

dump-0.4b41-14
e2fsprogs-1.38-25
kernel-default-2.6.16.13-4
glibc-2.4-25
gcc-4.1.0-25

Please let me know if there's any other information you would like.

-- Bob Rogers

Discussion

  • Bob Rogers

    Bob Rogers - 2007-09-21

    Successful L0 plus failed L1 transcript

     
  • Stelian Pop

    Stelian Pop - 2007-09-21
    • assigned_to: nobody --> stelian
     
  • Bob Rogers

    Bob Rogers - 2007-09-28

    Restore failure using dumps created by 0.4b41 and libext2fs 1.28

     
  • Bob Rogers

    Bob Rogers - 2007-09-28

    Logged In: YES
    user_id=603349
    Originator: YES

    The restore still fails using dumps created from the same partition with the current released version of the software.
    File Added: new-restore-transcript.text

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks