"undo" Supersize active window

2010-11-20
2013-03-06
  • AnniePerson

    AnniePerson - 2010-11-20

    "Supersize active window" is the key feature that I use very often. Would it be possible to implement an "undo" for it? To clarify what I mean: if I maximise or minimise the active window, a second push on the according key brings the window size back to its previous, non-maximised or non-minimised size. Is it possible to have the same behaviour also for supersize?

     
  • AnniePerson

    AnniePerson - 2010-11-20

    talking about SwapScreen, of course

     
  • AnniePerson

    AnniePerson - 2010-11-20

    It seems to be an error. I moved the wondows taskbar to the left edge of the left screen and "undo" of supersize doesn't work. With the taskbar on the lower edge of the window as it is the default it works fine.

     
  • Gerald Evans

    Gerald Evans - 2010-11-20

    I think I can see what is happening, so I should be able to fix this.
    It will work if on the taskbar you select 'Auto-hide the taskbar' or unselect 'Keep the taskbar on top of other windows', but I realise not everyone would want to use these options.

     
  • AnniePerson

    AnniePerson - 2010-11-20

    Would be great if you could fix it. Thanks in advance.

     
  • Gerald Evans

    Gerald Evans - 2010-12-28

    This has been fixed in version 1.6 which has just been released.

     
  • AnniePerson

    AnniePerson - 2010-12-31

    Thanks a lot. I downloaded  v 1.6, it works great.

     
  • c2k

    c2k - 2012-02-07

    If I need to start a new thread please let me know…
    Maybe I am misunderstanding post 5 above, but it sounded like you were going to make it follow the same rules as a normal maximize (e.g., the window stops at the taskbar when it is not set to auto-hide).  I am using version 1.8 and when supersize is used the window goes under the taskbar all the way to the bottom of the screen.

     
  • Gerald Evans

    Gerald Evans - 2012-02-07

    If you have 2 screens of the same resolution arranged left and right, and you have the taskbar at the bottom, then I would expect the behavior you are seeing.  What's happening is that it is trying to find the smallest rectangle that covers all of the usable screen space on all of your monitors. As your monitor without the taskbar  offers more vertical resolution, this is the height that will be used for the supersized window.  A similar problem will occur if you have screens with different vertical resolutions.

    I'll have a look at adding an option to supersize or a new hotkey that restricts the supersized window so that it is fully visible on all of the screens.

     
  • c2k

    c2k - 2012-02-07

    Thank you for looking into it.
    As a work around for now, I have set the window to the maximum size without going under the taskbar, and am using a user defined area.  I get the same result, just requires a little more setup.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks