Install problem - SuSE9.1

Help
robert_sf
2004-08-29
2004-09-01
  • robert_sf

    robert_sf - 2004-08-29

    i am having a problem getting drPython to work on a SuSE9.1 box.
    can anyone provide some suggestions on what i should be doing to get it to run?
    thanx - robert

    Installed:
    SuSE9.1
    python-wxGTK 2.4.2.4-138
    wxGTK 2.4.2.4-138
    wxGTK-gl 2.4.2.4-138
    python 2.3.3-85

    In Python:
    >>>help()
    >modules
    lists: wx (package) and wxPython (package) as available to Python.

    Trying to run: drpython.py (after modifying: " #!/usr/bin/python " from " #!/usr/bin/env python ") brings up the following err. msgs.:

    ^[[ATraceback (most recent call last):
      File "~/MyProjects/Python/drpython-3.4.1/drpython.py", line 3267, in ? app = DrApp(0)
      File "/usr/lib/python2.3/site-packages/wxPython/wx.py", line 1951, in __init__
        _wxStart(self.OnInit)
      File "~/MyProjects/Python/drpython-3.4.1/drpython.py", line 3258, i              n OnInit
        frame = DrFrame(None, 101, "DrPython - Untitled 1")
      File "~/MyProjects/Python/drpython-3.4.1/drpython.py", line 486, in               __init__
        self.mdinotebook = drNotebook(self, -1, wx.DefaultPosition, wx.Size(WindowWi              dth, WindowHeight), wx.CLIP_CHILDREN)
      File "                                               ~/MyProjects/Python/drpython-3.4.1/drpython.py", line 91, in               __init__
        self.Bind(wx.EVT_LEFT_DOWN, self.OnFindFocus)
    AttributeError: drNotebook instance has no attribute 'Bind'

    drPython 3.4.1 unzipped in /home/user directory and being run from there. is this ok?

     
    • Franz Steinhaeusler

      Welcome to the club :)

      you need to install wxPython 2.5, then everything
      will be ok.
      Bind for example is new in 2.5.

      Franz

       
    • robert_sf

      robert_sf - 2004-08-29

      hi Franz-
      thanx for the welcome. :-)

      installed wxPython 2.5 along with gtk+ from a redhat rpm using YAST. tried to start drPython 3.4.1, it comes up with some new messages :-) can you help? thanx

      Traceback (most recent call last):
        File "/home/bobert/MyProjects/Python/drpython-3.4.1/drpython.py", line 45, in ?
          import wx, wx.stc, drScrolledMessageDialog
        File "/usr/lib/python2.3/site-packages/wx/__init__.py", line 42, in ?
          from wx._core import *
        File "/usr/lib/python2.3/site-packages/wx/_core.py", line 4, in ?
          import _core_
      ImportError: /usr/lib/python2.3/site-packages/wx/_core_.so: undefined symbol: PyUnicodeUCS2_AsWideChar

       
    • Franz Steinhaeusler

      Hello Robert,

      sorry, I have no answer (I run drPython only on Windows Xp)
      the wxPython Demo is working?

      what I've found in google:
      You'll probably need to remove the shared modules that were built with
      the different UCS setting, then "make" again.

      I've expanded my config options from --with-pydebug to include
      --enable-unicode=ucs4

      maybe this ?

       
      • robert_sf

        robert_sf - 2004-08-30

        hello Franz-

        You may have hit on it. wxPython, the demo, used to run before upgrading it to 2.5, now not. So, it doesn't seem to have anything to do with drPython. I will explore your suggestion. In the mean time, it's back to IDLE:-). I'm a newbie in this world of Python, having been captured by the "elegance" of the language and M.Lutz's presentation of it in his book "Learning Python".

        thanx-robert

         
    • Daniel Pozmanter

      Ahoy,

         Did you install the GTK2 or GTK version?  2.5.1.x or 2.5.2.x?

         Plus, you need to uninstall the older versions of wxPython, or stuff can misbehave.

         Try uninstalling wxPython,
      and download from the wxPython website the latest
      for your version of python.

      Hope this helps,
      Dan

       
      • robert_sf

        robert_sf - 2004-09-01

        Thanks Franz, thanks Don.

        I removed the wxPython that SuSE installed and opted for the wxpythonGTK-Python2.3 RedHat rpm from the wxpython site. RPM installed clean and lo and behold drPython came to life.

        Have not pursued it past that point yet.

        robert

         

Log in to post a comment.