#16 Mac OS Starter Script broken

closed
nobody
None
5
2004-07-06
2004-06-20
No

The Mac OS Starter Script (v1.0.0) closes after about a second
without showing an error alert or sending anything to the console,
on at least this configuration: Mac OS 10.3.4, Python 2.3.4, and
DrPython 3.0.2.

vorn@nightstar.net

Discussion

  • Dan Uznanski

    Dan Uznanski - 2004-06-21

    Logged In: YES
    user_id=523026

    Oh, and wxPython 2.5.1.

    Vorn

     
  • Daniel Pozmanter

    Logged In: YES
    user_id=796750

    Alright.... A couple questions from the good doctor:

    1. Have you tried the latest DrPython? There was a launch
    error fixed for 3.0.3? (3.0.5 should be out shortly).
    2. Does DrPython launch without the script?
    3. Does DrPython 2.4.6 work with the script?

    I want to figure out if this is a problem with the main
    program, or with the starter script.

     
  • Dan Uznanski

    Dan Uznanski - 2004-06-23

    Logged In: YES
    user_id=523026

    Just tried it with 3.0.6 - same failure, basically. You guys are updating
    fast lately. :)

    Also tried running drpython.py straight - had to change the #! line to /
    usr/bin/python, but you warned about that. This gives me the error "no
    such module wx" ... which means that it's not looking in the right place
    for the wxpython modules. I don't know where the wxPython package
    installed those. Not sure what to do about that, the wxPython
    documentation is less than clear on this subject. It appears to assume
    that I'm working with MacPython, which I could never convince to open
    any modules whatsoever and so threw out on account of it being useless.
    Meh. Looks like this isn't about the starter script anymore, going to need
    to write a whole new set of instructions. I'll see what I can come up with
    and post it somewhere useful.

    (by the way it may be a good idea to up and say "Run drpython.py!"
    somewhere in your documentation, it's not exactly, y'know, crystal
    clear.)

    Vorn

     
  • Daniel Pozmanter

    Logged In: YES
    user_id=796750

    Hmmm. Does the 2.5.1.5 wxDemo work?

    This sounds like something is wrong with your wxPython
    installation. Try reinstalling everything via the instructions on
    the wxpython site. It may be that wxPython 2.5.1.5 is not
    mature enough for use on the mac (wxPython 2.5.1.5 for
    GTK2 is not fully implemented, even though it was released).

    Unfortunately, DrPython 3.x.x requires 2.5.1.5 or later.

    Try DrPython 2.4.6, does that work?

     
  • Daniel Pozmanter

    Logged In: YES
    user_id=796750

    Closing, as this sounds like an installation issue, and I have
    not heard back. If this is incorrect, give a holler (and some
    more info), and I'll repopen, and look into it.

     
  • Daniel Pozmanter

    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks