I am still hitting the problem with my Mach64 module:

(EE) ATI(0): [dri] ATIDRIScreenInit failed because of a version mismatch.
[dri] mach64.ko kernel module version is 2.0.0, but version 1.0 or greater is needed.
[dri] Disabling DRI.

I tried building the Xorg with servers from sources, same problem.
My next idea is to remove the version-check, but this would not be
the intended way it ought to be. Also i thought about setting
the kernel version to 1.1 instead of 2.0.0, but this is also not the
intended way.

Now after building everything from source i ask here once more for help.
(everything refers to xservers, xorgdrivers, mesa, drm....)

Running:
Debian Lenny
Xorg 7.1.1(7.1.0)
git mesa
git drm
....

Need help for sure, im totally lost now (except my crazy ideas about changing version numbers)

Sebastian