Thomas Hellström wrote:
Benno Schulenberg wrote:
Hi Thomas,

You wrote:
  
OK, could you mail me your kernel config, 
    

Attached.

  
and also make sure the 
via_agp (via-agp?) module gets loaded properly.
    

Ehm, I disabled that in the config while trying to find the cause 
for the problem, because it didn't seem needed, as it didn't get 
automatically loaded when doing modprobe via, and its presence 
seemed to cause panics instead of oopses.

Benno
  
Yes, I can reproduce the problem here, on 2.6.11.6. In fact, the via module never initializes properly as it doesn't print out the version info etc. This seems to cause an oops on exit.

I'm not sure wether this is via-specific or drm-specific. Anyone with a clue?

/Thomas

OK, just tried to modprobe i915 and sis with the same result, so it is apparently not via-specific.
The driver calls drm_init() but never gets there. A debug statement at the beginning of drm_init() is never printed.

Sounds like maybe the wrong drm.ko is loaded, but there is no such stuff lying around. Also drm is not enabled in the kernel config.

Does anyone have a working set of CVS drivers with 2.6.11.6?

Regards,
Thomas