#426 Can't use gdb

Other
open
nobody
Other (69)
5
2002-05-01
2002-05-01
No

When I have the dri option enableed in the
XF86Config-4, and I tray to debug a program I get this:
This GDB was configured as "i386-mandrake-linux"...
(gdb) run
Starting program:
/home/trailcode/glut-3.7/progs/demos/skyfly/skyfly
[New Thread 1024 (LWP 2892)]
Loading required GL library /usr/X11R6/lib/libGL.so.1.2

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread 1024 (LWP 2892)]
0x40555107 in __driCreateScreen () from
/usr/X11R6/lib/modules/dri/r128_dri.so
(gdb)

This is very annoying.

kernelversion

2.4

X -version

XFree86 Version 4.1.0 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 2 June 2001
If the server is older than 6-12 months, or if
your card is
newer than the above date, look for a newer
version before
reporting problems. (See
http://www.XFree86.Org/FAQ\)
Build Operating System: Linux 2.4.8-5mdkenterprise i686
[ELF]
Module Loader present

Also some times when I load a openGL program combined
with www.trolltech.com's QT my screen locks up can't
use the mouse!

But I know the kernal is still running, because if I do
some thing like this the system recovers.

./openGL-and-QT-program & sleep 10 && kill 1234

The program will freez the screen and the mouse, but
after 10 secs the program is killed and the system is
back to normal.

If the program is run again there is no problems.

I am using a Dell Latitude C800 with a ATI Mobility M4
32M

Thanks,
Matthew Tang (mltang@carbon.cudenver.edu)

Discussion


Log in to post a comment.