#408 DRI libGLU?.so lets application crash

open
nobody
ATI OpenGL (71)
5
2002-02-15
2002-02-15
Anonymous
No

I am working on a GTK/OpenGL application and
got crashes within the gluBuild2DMipmaps() function when
using hardware-accelerated OpenGL-library from DRI.
If i disable hardware-accelerated rendering with the
ENV-vars or linking against the original Mesa-lib it
doesn't crash.

Here is a samble backtrace:
#0 chunk_alloc (ar_ptr=0x404ef5a0, nb=80) at malloc.c:2926
#1 0x40444f8d in __libc_calloc (n=1, elem_size=72) at
malloc.c:3827
#2 0x4064fbba in _mesa_alloc_texture_image ()
from /usr/X11R6/lib/modules/dri/radeon_dri.so
#3 0x40651512 in _mesa_TexImage2D ()
from /usr/X11R6/lib/modules/dri/radeon_dri.so
#4 0x400f43fd in gluBuild2DMipmapLevelsCore () from
/usr/X11R6/lib/libGLU.so.1
#5 0x400f4625 in gluBuild2DMipmaps () from
/usr/X11R6/lib/libGLU.so.1
...

I got it while using MALLOC_CHECK_=2, libefence or njamd.
They all detected a corruption there or something other,
which caused that crash.
The programm runs well with Software-rendering and the
nVidia-libGL.

Tested with DRI from Xfree 4.1.0 and from Xfree 4.2.0
Kernel 2.4.16
Feb 15 08:11:53 localhost kernel: [drm] AGP 0.99 on VIA
Apollo KT133 @ 0xe6000000 32MB
ATI Radeon 7200

I am willing to help in anyway to debug this. For
any questions, e-mail me (elmex@x-paste.de)

Discussion


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks