#338 wants newest core, but I have it

Build/Compile Fails
closed
5
2003-07-01
2001-05-17
Scott Healy
No

I have Mandrake 8.0 with the latest kernel 2.4.3-20
mdk. but when I type ./install, I get a message
telling me "The DRI drivers can not be installed
without the latest kernel modules. Installation will
be aborted. See the dri.log for information on what
went wrong."

The dri.log says :

cc -O2 -Wall -Wwrite-strings -Wpointer-arith
-Wcast-align -Wstrict-prototypes -Wnested-externs
-Wpointer-arith -D__KERNEL__ -DMODULE
-fomit-frame-pointer -DCONFIG_AGP -DCONFIG_AGP_MODULE
-DMODVERSIONS -include
/usr/include/linux/modversions.h
-DKILLFASYNCHASTHREEPARAMETERS -DEXPORT_SYMTAB
-I/usr/include -c radeon_drv.c -o radeon_drv.o
In file included from radeon_drv.c:1:
/usr/include/linux/modversions.h:1:2: #error Modules
should never use kernel-headers system headers,
/usr/include/linux/modversions.h:2:2: #error but
headers from an appropriate kernel-source
make: *** [radeon_drv.o] Error 1

I have no idea how to interpret this.

I have a Radeon VE AGP 32 MB DDR card.

Thanks.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    have you install the kernel sources ???

    i've got the same prob before :)

     
  • Ian Romanick

    Ian Romanick - 2003-05-12

    Logged In: YES
    user_id=423974

    There used to be some problems with the way that the DRI
    snapshots found kernel source. Can you reproduce this
    problem with a recent DRI snapshot?

     
  • Ian Romanick

    Ian Romanick - 2003-05-12
    • assigned_to: nobody --> idr
     
  • Ian Romanick

    Ian Romanick - 2003-07-01
    • status: open --> closed
     
  • Ian Romanick

    Ian Romanick - 2003-07-01

    Logged In: YES
    user_id=423974

    I have been unable to reproduce this bug or make contact
    with the bug's submitter. Closing.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks