TFTP max session limit? (Clonezilla)

Help
2016-09-20
2016-10-02
  • Peter Kuykendall

    Hi Steven -

    I have been running Clonezilla for several years with few problems. Until now we never needed to PXE boot more than about 8 PCs at once. Now we do. I find that when more than about 10 - 15 come up at once (unsure exactly how many), the later ones will stall. They will get an IP address and a message saying that they are fetching initrd (I think), but nothing will happen until one of the other sessions completes. At that point the stalled machine will start up as normal.

    It's acting like the TFTP server is imposing a maximum connection limit. Is this the case? Is there a way to raise the limit?

    I'm sorry about the vague error messages. I will be back in front of the environment in a few days and can get more precise info, including screen shots, if desired.

    Thanks - Pete

     
  • Steven Shiau

    Steven Shiau - 2016-10-02

    "Is there a way to raise the limit?" -> Not really.
    You can debug it by adding the verbose option of tftp server, e.g., for Ubuntu, you can edit
    /etc/default/tftpd-hpa
    add -v to TFTP_OPTIONS, i.e. mkae it lie:
    TFTP_OPTIONS="--secure -v -v -v "
    Then restart the service by "service restart tftpd-hpa".
    After that, check /var/log/syslog to see if you can find any clues why.

    Steven

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks