#374 ant build does not copy over all plugins

closed-fixed
margotc
Build (3)
2
2012-05-17
2011-10-24
No

When ant is run to build dpr it seems that two plugins directories are created, one in the base directory and one in the dist directory. The plugin directory in the dist directory does not seem to correctly gain all the plugins and needs to be corrected by separately running from the xena/xena directory:

ant -f build_plugins.xml send_to_dpr

Discussion

  • Terry O'Neill

    Terry O'Neill - 2011-11-14

    Fixed in testing branch:
    Doesn't really seem necessary to have the second plugin directory after all. I have fixed the working directory used in eclipse based on the DPR.launch file so running from Eclipse will work fine. The build has not been changed.

     
  • Terry O'Neill

    Terry O'Neill - 2011-11-14
    • priority: 5 --> 4
    • labels: --> Build
    • assigned_to: nobody --> terryoneill
    • status: open --> open-fixed
     
  • margotc

    margotc - 2012-02-28

    check to make sure build is in dist/plugins

     
  • Terry O'Neill

    Terry O'Neill - 2012-04-24
    • assigned_to: terryoneill --> margotc
     
  • Terry O'Neill

    Terry O'Neill - 2012-04-24

    Tested and confirmed that this fixes the issue when running from Eclipse.

    The details should say that the plugins directory in the base directory of dpr does not gain all the plugins. This was only an issue because the previous setup of the DPR.launch file used the base directory when running from Eclipse. Note that the actual copying to the plugins directory in the base directory of DPR is done in the Xena office plugin ant build file and the Xena NAA plugin ant build file. This is fixed by by the resolution of bug-3520786 although this fix is not necessary to allow this issue to be fixed (it will just mean that the plugins directory in the base directory is still there but unused). Also note that the as mentioned in the description the send_to_dpr target in the Xena build_plugins.xml ant build file does create a plugins directory in the base directory of dpr, however this target is not used by the dpr ant build. The issue with this build file is referred to in Xena rfe-3520788.

    Assigned this bug to Margot to confirm that she finds the same results. Note that without this fix DPR will run correctly but will not have the correct plugins as can be seen for the Xena Settings menu item (and will thus be unable to normalise certain file types in the desired manner).

     
  • margotc

    margotc - 2012-05-16

    I have seen the same behaviour occurring. Should we just prevent the base plugins directory from building in the build.xml file? We could probably change the priority of this since it doesn't really cause any failures.

     
  • Terry O'Neill

    Terry O'Neill - 2012-05-17

    Lowered the priority for this bug. The fix itself is only to the DPR.launch file which is used when running the program from Eclipse (only done for development). The change you mention of preventing the base directory from being built is present as bug-3520786 in the Xena bug tracker. This bug has been resolved and will be in the Xena 6.0.1 release.

     
  • Terry O'Neill

    Terry O'Neill - 2012-05-17
    • priority: 4 --> 2
     
  • margotc

    margotc - 2012-05-17

    Closing this. Tested with new Xena build (6.0.1- testing) and no base plugins directory is created.

     
  • margotc

    margotc - 2012-05-17
    • status: open-fixed --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks