#147 common-collections 3.0

Dozer v.4.3
closed
5
2008-11-25
2008-10-31
No

Currently Dozer depends on version 3.1 of commons-collections. In a project we are an environment which already depends in version 3.0 (Websphere Portal 6.0).

Dozer only depends in two locations on version 3.1, both using a default constructor of ListOrderedSet which is not present in common-collections 3.0. The default constructor can be replaced a call to decoratie a new ArrayList. All junit tests keep running. Dozer can than depend on version 3.0 and be used in the Websphere Portal 6.0 environment.

Attached is patch for this change.

Discussion

  • Gert Jan Kersten

    Patch to change depency to commons-collections 3.0

     
  • dmitry (lv)

    dmitry (lv) - 2008-11-24
    • labels: --> Technology Integration
     
  • dmitry (lv)

    dmitry (lv) - 2008-11-24

    I think this change can be included in the next release. But of course you will have to switch library on your own. The distribution will come with 3.1 as always.

     
  • dmitry (lv)

    dmitry (lv) - 2008-11-25
    • milestone: 478636 --> Dozer v.4.3
    • assigned_to: nobody --> buzdin
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks