#85 Throw exception if map-id cannot be resolved

closed
None
5
2007-04-27
2007-04-24
No

Hi,

We have recently tried to upgrade from version 2.2 of Dozer to 3.2. We are
experiancing problems when calling

DozerBeanMapper.map( source, target, mapid )

In version 2.2 of Dozer, if the map-id could not be resolved it would throw
a MappingException. However, this no longer seems to be the case. Instead
it logs a warning and attempts a generic transformation. We have inspected
the source code and this is confirmed. Is there any way of making dozer
3.2 follow the same scemantics as 2.2?

Thanks

Steve

Discussion

  • Matt Tierney

    Matt Tierney - 2007-04-25

    Logged In: YES
    user_id=1236069
    Originator: YES

    fixed

     
  • Matt Tierney

    Matt Tierney - 2007-04-25
    • status: open --> pending
     
  • Matt Tierney

    Matt Tierney - 2007-04-27
    • status: pending --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks