#3 field-deep error indicates it may not be supported by 1.4

closed
5
2005-08-15
2005-08-10
Anonymous
No

I get the following error while using dozer

10 Aug 2005 10:31:11,843 ERROR Mapper []:
Error in loading dozer mapping
file: /dozerBeanMapping.xml :
org.xml.sax.SAXException: Parsing Error
Line: 114
URI: null
Message: cvc-complex-type.2.4.a: Invalid content was
found starting with element 'field-deep'. One
of '{"":field, "":field-dehydrate, "":field-method, "":field-
iterate-method}' is expected.

My dozer xml file where the only place I use field-deep
is:

<field-deep>
<A>hierarchyLevel</A>
<B>itemType.tradeItemUnitDescriptor</B>
</field-deep>

Why would I get this message? Is not field-deep
supported in 1.4?

Thanks

Discussion

  • Franz Garsombke

    Franz Garsombke - 2005-08-10
    • assigned_to: nobody --> fgarsombke
     
  • Franz Garsombke

    Franz Garsombke - 2005-08-10

    Logged In: YES
    user_id=550744

    field-deep is supported in 1.4 We have a suite of unit tests
    built around that functionality. Someone else was having
    this exact error and I could not reproduce it. Just curious
    what JDK you are using?

     
  • Ben Sullins

    Ben Sullins - 2005-08-12
    • status: open --> closed
     
  • Franz Garsombke

    Franz Garsombke - 2005-08-13

    Logged In: YES
    user_id=550744

    There is a bug with the XSD. It appears there is no ryhme
    nor reason to when this appears. It has to do with the
    ordering of the elements in your xml file. I am trying to
    track this down...

     
  • Franz Garsombke

    Franz Garsombke - 2005-08-13
    • status: closed --> open
     
  • Franz Garsombke

    Franz Garsombke - 2005-08-13

    Logged In: YES
    user_id=550744

    I tracked it down to the xsd <sequence> tag:

    Sequence Indicator:

    The <sequence> indicator specifies that the child elements
    must appear in a specific order:

    Unfortunately, our <field-xx> tags are not in a certain
    order. There is an XSD <any> tag but you can only have 0 -1
    objects.

    I will try to find a work-around in the xsd. If I can't we
    will have to turn off xsd validation since we can not
    enforce the order of <field> tags in the mappings.

     
  • Franz Garsombke

    Franz Garsombke - 2005-08-15

    Logged In: YES
    user_id=550744

    dozer 1.4.3 fixes this problem. We no longer use XSD because
    of its limitations. I have moved dozer to DTD validation.

     
  • Franz Garsombke

    Franz Garsombke - 2005-08-15
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks