installation problem

Help
Mike Reed
2003-08-21
2013-05-08
  • Mike Reed

    Mike Reed - 2003-08-21

    Hi,
    I have Xemacs-21.1.14 and some directories left over from a removed installation of emacs.  I downloaded doxymacs 1.5.0 and configured/made/installed as per instructions with no problems.
    It installed the lisp files in:
    /usr/share/emacs/site-lisp/
    When I ran xemacs it couldn't seem to find doxymacs.  No Options->Customize->Emacs->Programming-Tools->Doxymacs
    and nothing with Alt-x.  I tried adding
    (setq load-path (cons "/usr/share/emacs/site-list" load-path))
    to my .emacs but it seemed to make things worse.
    Is there some trick to installing doxymacs when you only have Xemacs installed and not emacs.  The thing is, I usually add things to my Xemacs using the package management so this is all a bit new to me.
    Thanks for any help.
    Mike.

     
    • Ryan T. Sammartino

      You can pass various options to "configure" for XEmacs only install.

      Try ./configure --help, and pay particular attention to the EMACS env. variable and --with-lispdir.

      Lemme know if that helps or not.

       
      • Mike Reed

        Mike Reed - 2003-08-27

        In a word, no.

        I have to admit I am no xemacs admin/developer.  The problem seemed to me that xemacs (I have 21.1.14) adds functionality via packages, so how does one add functionality with some non-packaged lisp (I had a look at how one creates xemacs packages and I really haven't got time for that).  I couldn't find one piece of information that described how to do this but after reading lots of stuff on the xemacs.org website I have managed to cobble something together that works.

        The best guess as to where to put non-packaged lisp which wasn't official xemacs was:

        {prefix}/lib/xemacs/site-packages/lisp

        So I put doxymacs.el(c) and xml-parse.el(c) there  (normally non-official xemacs packages would go in subdirectories in this directory).  Unfortunately, xemacs did not automatically load these files.  I had to use meta-x: load-library: doxymacs, but at least xemacs found the files!  To have it loaded automatically for all users I created a file:

        {prefix}/lib/xemacs/site-packages/lisp/site-start.el

        and put in it:

        (load "doxymacs")

        Now I have the functionality when I start xemacs including Options->Customize->Emacs->Programming->Tools->Doxymacs.  If there are any xemacs admin/developers out there who can tell me if I have done anything wrong please let me know.  Please don't tell me I should have created a package, I already know that.

        Mike.

         
        • Mike Reed

          Mike Reed - 2003-08-29

          PS.  I forgot to ask.  Given what is in your INSTALL instructions I was wondering what the difference between
          (require 'doxymacs)
          and
          (load "doxymacs")
          is?

           
  • txomon

    txomon - 2012-01-17

    I also have the same problem. I am using the GNU emacs provided by emacs Ubuntu package. I achieved installing things in /usr/local/share/emacs/site-lisp/ by doing:

    ./configure -with-lispdir /usr/share/emacs/site-lisp && make && sudo make install

    But it doesn't load at the beginning,  I tryed via M-x load-library and doxymacs, but doesn't show up. I also tried by loading all the rest but they don't show up.

    Help is welcome.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks