#532 ser_demux expansion not working

fixed_in_git
closed
None
5
2014-05-14
2014-05-13
No

Hi,

using the ser_demux built there is still the same issue occuring. The saw starts moving but doesn't finish calibrating.
I started dosemu, ran pccom.bat, did mode com2:96,n,8,1 + mode com5:96,e,8,1 and started the program, began with calibrating which isn't finishing and has to be interrupted.
Attached -D9+Tsi log.

1 Attachments

Discussion

  • Stas Sergeev

    Stas Sergeev - 2014-05-13

    Should be fixed now in git.

     
  • Hans-Christian Koch

    Impressive! I restarted machine to initiate a full calibration and still works. Attached the log.
    Next step for me is to test wether cutting works, too. This may take some time as I have to set up some parameters. In addition to that an employee told me that the COM5 cutting isn't working properly on the old PC since a few days so I have to check that one first (otherwise I may complain about errors not belonging to dosemu ;) ).
    I will merge vga and demux built now, otherwise I can't continue testing.

     
  • Hans-Christian Koch

    Very well done, seems to work. They're testing this for a week now and then I will ask them whether any problems occured - I think this can be closed.
    Will this also work for programs which make use of all 4 serial ports of PCCOM (COM5,COM6,COM7,COM8)? Some machines also have a second PCCOM card so they have COM 1 and 2 + COM5 - 12.

     
  • Stas Sergeev

    Stas Sergeev - 2014-05-14

    Should work but who knows. :)

     
  • Stas Sergeev

    Stas Sergeev - 2014-05-14
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks