morphos build

kas1e
2014-05-08
2014-05-08
  • kas1e

    kas1e - 2014-05-08

    While we do not have morphos developers there anymore, and 5.9 release are out of question for morphos then, i still spend sometime to make it at least builds/runs, as well as will try to play with 64bit and screentitle code.

    Through, what i found for now, is that when i run morphos version from icon : it runs fine without additional stuff. But if i run from shell, then when dopus5 screen opens with lister and stuff, it also open for me "Mixer" prefs program. Wtf :)

     
    Last edit: kas1e 2014-05-08
  • kas1e

    kas1e - 2014-05-08

    Tested -DUSE_SCREENTITLE for morphos, seems works fine as well. Commited

     
  • kas1e

    kas1e - 2014-05-08

    Tested -DUSE_64BIT for morphos, all works fine too. Commited.

     
  • kas1e

    kas1e - 2014-05-08

    And tried to build morphos version with -DDRAW_ICONSTATE (was in hope, that at least those icons which visibly in morphos, will looks fine, just png/ambient ones will be the same). But in end, once i enable it, all icons just disappear.

    I.e. there is 2 attachments. One as it now (i.e. no DRAW_ICONSTATE), and another with enabled DRAW_ICONSTATE for program and icon module.

    I can understand that for example ambient's png icons just disappear, but strange why os4's ones disappear too. Probably need some ambient specific code in those parts where DRAW_ICONSTATE was added ?

     
    Last edit: kas1e 2014-05-08

Log in to post a comment.