Thanks.  I went into Synaptic and did a complete removal of 0.4 and my problem went away.

On Fri, Oct 17, 2008 at 9:07 AM, David Goodger <> wrote:
optOn Fri, Oct 17, 2008 at 07:50, Ryan Krauss <> wrote:
> I had docutils 0.4 installed from the ubuntu repositories.  I am trying to
> upgrade to 0.6 from the tarball and am having some issues.  Originally,
> was listed as already installed, so I deleted (and
> .pyc) hoping that would solve the problem.
> Are there other things I need to do to uninstall 0.4 first?  Or is there
> some other problem?

Did you uninstall Docutils 0.4 via Ubuntu's package management (using
Synaptic or apt-get etc.)?

I don't know why you're getting this error. It may be a version
mismatch. Python 2.5 doesn't need, it should be in
/usr/lib/python2.5/ already, and Docutils's should detect it
and not install it. is provided by the python2.5-minimal
package. Try the following:

* Verify that /usr/lib/python2.5/ exists. If it doesn't,
verify that the python2.5-minimal package was installed (it's a
dependency of python2.5). Reinstall if necessary.
* Remove & .pyc from /usr/lib/python2.5/site-packages.
* Remove the ~/software/docutils/build/ directory, which may still
have copies of & .pyc.
* In ~/software/docutils/, run "sudo python install" again.

If that doesn't work, let us know: your version of Ubuntu, and the
versions of the python2.5 & python2.5-minimal packages installed.

David Goodger <>