Shadyr - 2008-05-29

If your configure sees M4, but then exits claiming that it could not find GNU m4, here is a fix.  Sometime between m4 1.4.8 and 1.4.10, the output of "m4 --version" was changed, so systems with the newer versions of m4 fail the check.

This is for docsis-0.9.5.

Edit your configure file.  Go to line 19513, which should look like this:

  ac_is_gnu_m4=`echo $ac_m4_vers | cut -d' ' -f1`;

Change it to look like this:

  ac_is_gnu_m4=`echo $ac_m4_vers | cut -d' ' -f2`;

It should now complete the configure.