Encoding problem in Windows version of DOCSIS

Anonymous
2004-06-21
2004-07-21
  • Anonymous - 2004-06-21

    Hello,
    i have a problem with encoding .cfg file to CM config file while using almost all of the examples of config files except only those with basic parameters such as file "docsis1.0_basic", these work fine. Encoding passes, but when i open it in Config Edit program or start the cable modem using this file, modem freezes. In Config Edit it displays this:

    network_access = on;
    down_freq = 123000000;
    up_chan_id = 1;
    cos {
       class_id = 1;
       max_down_rate = 512000;
       max_up_rate = 64000;
       up_chan_prio = 3;
       min_up_rate = 32000;
       max_burst_size = 1700;
       cos_bpi_enable = enabled;
    }
    bpi {
       authorize_wait_timeout = 13;
       Baseline Privacy Option, type = 10, len = 2, value = 0x04 0x00;
       Baseline Privacy Option, type = 0, len = 0, value =;
       Baseline Privacy Option, type = 13, len = 10, value = 0x03 0x04 0x00 0x00 0x02 0x58 0x04 0x04 0x00 0x00;
       Baseline Privacy Option, type = 0, len = 13, value = 0x0a 0x05 0x04 0x00 0x00 0x00 0x0d 0x0a 0x06 0x04 0x00 0x00 0x02;
    0057:  Error: Value length exceeds size, skipping 42 bytes
    }

    Source file is "docsis1.0_filters2_oidnum.cfg" from examples dir, which i think appears to be correct.
    I use Windows version of the docsis program and i need it working correctly. Do you have any idea, where could be the problem?
    Thank you.

     
    • Arvydas Burgis

      Arvydas Burgis - 2004-07-21

      See BUG report ID 988304 and patches section

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks