Arvydas Burgis - 2004-05-18

Hi everybody,

Just ran into problem using docsDevFilterIP. Below is an extract of my config file that works. Problems start if i ad one more accept block (third IP) - with such config file CMs don't boot (complaining about missing parameters). I have Thomson TCM390 and Arris CM450B. The most confusing thing is that Thomson works with 4 accept blocks and Arris doesn't, also both work with 2 and 5 accept blocks, and both doesn't with 3 accept blocks.
  Did anyone have similar problems or know what might cause such strange behavior and how to fix it?

Equipment used: "Thomson TCM390" and "Arris CM450B" with "Arris Cadant C3" CMTS.
DOCSIS version 0.9.0 win32 binaries.

    SnmpMibObject docsDevFilterIpStatus.1 Integer 4; /* createAndGo */
    SnmpMibObject docsDevFilterIpControl.1 Integer 2; /* accept */
    SnmpMibObject docsDevFilterIpIfIndex.1 Integer 1 ;
    SnmpMibObject docsDevFilterIpDirection.1 Integer 1; /* inbound */
    SnmpMibObject docsDevFilterIpSaddr.1 IPAddress 212.xxx.xxx.xxx ;
    SnmpMibObject docsDevFilterIpSmask.1 IPAddress 255.255.255.255 ;
    SnmpMibObject docsDevFilterIpStatus.2 Integer 4; /* createAndGo */
    SnmpMibObject docsDevFilterIpControl.2 Integer 2; /* accept */
    SnmpMibObject docsDevFilterIpIfIndex.2 Integer 1 ;
    SnmpMibObject docsDevFilterIpDirection.2 Integer 1; /* inbound */
    SnmpMibObject docsDevFilterIpSaddr.2 IPAddress 212.xxx.xxx.xxx ;
    SnmpMibObject docsDevFilterIpSmask.2 IPAddress 255.255.255.255 ;
    SnmpMibObject docsDevFilterIpStatus.3 Integer 4; /* createAndGo */
    SnmpMibObject docsDevFilterIpControl.3 Integer 1; /* discard */
    SnmpMibObject docsDevFilterIpIfIndex.3 Integer 1 ;
    SnmpMibObject docsDevFilterIpDirection.3 Integer 1; /* inbound */

Regards,
  Arvydas